Move packages from agl-core to agl-ivi 24/23124/3
authorRonan Le Martret <ronan.lemartret@iot.bzh>
Fri, 29 Nov 2019 09:17:56 +0000 (10:17 +0100)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Wed, 4 Dec 2019 13:04:17 +0000 (14:04 +0100)
Bug-AGL: SPEC-2500

v2: rename packagegroup-agl-ivi-navigation, remove duplicate

Change-Id: I4bbd4474768a84291e94877f3a6b5b4d5a3edc58
Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-platform/images/agl-image-ivi-crosssdk.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb
recipes-platform/packagegroups/packagegroup-agl-ivi-connectivity.bb
recipes-platform/packagegroups/packagegroup-agl-ivi-navigation.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb [new file with mode: 0644]

diff --git a/recipes-platform/images/agl-image-ivi-crosssdk.bb b/recipes-platform/images/agl-image-ivi-crosssdk.bb
new file mode 100644 (file)
index 0000000..93537fe
--- /dev/null
@@ -0,0 +1,2 @@
+# just for backward compatibility
+require recipes-platform/images/agl-image-minimal-crosssdk.bb
index 0edc600..acaa405 100644 (file)
@@ -18,14 +18,9 @@ RDEPENDS_${PN} += "\
     packagegroup-agl-ivi-connectivity \
     packagegroup-agl-ivi-graphics \
     packagegroup-agl-ivi-multimedia \
+    packagegroup-agl-ivi-navigation \
+    packagegroup-agl-ivi-services \
     "
-#    packagegroup-agl-ivi-automotive \
-#    packagegroup-agl-ivi-speech-services \
-#    packagegroup-agl-ivi-navi-lbs \
-#    packagegroup-agl-ivi-security \
-#    packagegroup-agl-ivi-os-commonlibs \
-#    packagegroup-agl-ivi-kernel \
-#
 
 RDEPENDS_${PN} += "\
     agl-login-manager \
index 2d45986..17d0d4b 100644 (file)
@@ -11,5 +11,10 @@ PACKAGES = "\
 ALLOW_EMPTY_${PN} = "1"
 
 RDEPENDS_${PN} += "\
+    bluez5-obex \
+    ${@bb.utils.contains("DISTRO_FEATURES", "3g", "libqmi", "", d)} \
+    rtl-sdr \
+    neard \
+    neardal-tools \
     ofono \
     "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-navigation.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-navigation.bb
new file mode 100644 (file)
index 0000000..90daf92
--- /dev/null
@@ -0,0 +1,17 @@
+SUMMARY = "The software for application framework of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL application framework which required by \
+Navigation and Location-Based Services Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-ivi-navigation \
+    "
+
+RDEPENDS_${PN} += "\
+    gpsd \
+    virtual/gpsd-conf \
+    geoclue \
+    "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
new file mode 100644 (file)
index 0000000..bc30aed
--- /dev/null
@@ -0,0 +1,30 @@
+DESCRIPTION = "The minimal set of packages for AGL IVI Connectivity Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-ivi-services \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+agl-service-bluetooth \
+agl-service-bluetooth-map \
+agl-service-bluetooth-pbap \
+agl-service-can-low-level \
+agl-service-geoclue \
+agl-service-geofence \
+agl-service-gps \
+agl-service-identity-agent \
+agl-service-iiodevices \
+agl-service-mediascanner \
+agl-service-navigation \
+agl-service-nfc \
+agl-service-signal-composer \
+agl-service-steering-wheel \
+agl-service-unicens \
+agl-service-weather \
+high-level-viwi-service \
+    "