Cleanup of recipes for CESdemo 15/4415/4
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Sat, 5 Dec 2015 12:46:17 +0000 (13:46 +0100)
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Tue, 22 Dec 2015 14:20:40 +0000 (23:20 +0900)
Small fix to the README.md adding a dependency.

2 fixes for the agl-demo-platform.bb
a) remove porter specifics, they moved to a bbappend in meta-renesas.
b) add CESdemo dependencies and install files in /opt by default.

v2: Fixed typo in agl-demo-platform.bb

v3: Add 'climatecontrolplugin' package to run CES2016 demo.

Change-Id: Id6d2d0b1cdcdf3dbc74309322544e0488a6a003c
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
README.md
recipes-platform/images/agl-demo-platform.bb

index eab32ca..dd08bc2 100644 (file)
--- a/README.md
+++ b/README.md
@@ -29,7 +29,7 @@ URI: git://git.yoctoproject.org/poky
 > revision: df87cb27efeaea1455f20692f9f1397c6fcab254
 
 URI: git://git.openembedded.org/meta-openembedded
-> layer:    meta-oe
+> layer:    meta-oe, meta-multimedia, meta-ruby
 > branch:   dizzy
 > revision: 9efaed99125b1c4324663d9a1b2d3319c74e7278
 
@@ -151,13 +151,10 @@ You can build a QEMU image using the following steps:
 2. Build the full image of AGL Demo Platform and applications
         $ bitbake agl-demo-platform
 
-  2a. Specifically If you are building the CES2016 demos you will want to add the following to your "conf/local.conf" file to install the demo code in the image:
-IMAGE_INSTALL_append = " CES2016-demo"
-
-  2b. If you want to run QEMU directly as VM in Virtual Box or your other favorite VM software then add this line to your "conf/local.conf" file. 
+  2a. If you want to run QEMU directly as VM in Virtual Box or your other favorite VM software then add this line to your "conf/local.conf" file. 
 IMAGE_FSTYPES += "vmdk"
 
-  2c. The Weston IVI-Shell always gets built ; it will not be started, however, unless you specify the following in your "conf/local.conf" file :
+  2b. The Weston IVI-Shell always gets built ; it will not be started, however, unless you specify the following in your "conf/local.conf" file :
 
 IMAGE_INSTALL_append = " \
     weston-ivi-shell-config \
index 79c5e25..a40680d 100644 (file)
@@ -15,10 +15,11 @@ IMAGE_INSTALL_append = " \
     packagegroup-agl-demo-platform \
     "
 
-# for Renesas R-Car2 M2 Porter
-IMAGE_INSTALL_append_porter = " \
-    gles-kernel-module \
-    libegl \
-    libgbm-dev \
+# add packages for CES2016 demo
+IMAGE_INSTALL_append = " \
+    CES2016-demo \
+    can-utils iproute2 \
+    python-curses \
+    dhcp-client \
+    climatecontrolplugin \
     "
-