Fix style issues in app recipes 18/25918/2
authorScott Murray <scott.murray@konsulko.com>
Thu, 14 Jan 2021 21:19:06 +0000 (16:19 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 15 Jan 2021 23:25:48 +0000 (23:25 +0000)
Update spacing and variable ordering in the demo app recipes for
consistency per the OpenEmbedded syle guide (see:
https://www.openembedded.org/wiki/Styleguide).  Additionally,
a common cut-and-pasted unnecessary comment has been removed from
the recipes.  There are no functional changes.

Bug-AGL: SPEC-3748

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Ic7cf3a1392678e76e8f512acb4f16b623fa35d3f

24 files changed:
recipes-demo/alexa-viewer/alexa-viewer_git.bb
recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb
recipes-demo/cluster-receiver/cluster-receiver_git.bb
recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
recipes-demo/dashboard/dashboard_git.bb
recipes-demo/homescreen/homescreen_git.bb
recipes-demo/hvac/hvac_git.bb
recipes-demo/launcher/launcher_git.bb
recipes-demo/mediaplayer/mediaplayer_git.bb
recipes-demo/messaging/messaging_git.bb
recipes-demo/mixer/mixer_git.bb
recipes-demo/navigation/ondemandnavi_git.bb
recipes-demo/navigation/poiapp_git.bb
recipes-demo/navigation/tbtnavi_git.bb
recipes-demo/onscreenapp/onscreenapp_git.bb
recipes-demo/phone/phone_git.bb
recipes-demo/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style_git.bb
recipes-demo/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb
recipes-demo/radio/radio_git.bb
recipes-demo/settings/settings_git.bb
recipes-demo/taskmanager/taskmanager_git.bb
recipes-demo/telematics-recorder/telematics-recorder_git.bb
recipes-demo/waltham-receiver/waltham-receiver_git.bb

index f73a97a..941c334 100644 (file)
@@ -7,20 +7,21 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 DEPENDS = " \
-       qtquickcontrols2 \
-       qlibhomescreen \
-       af-binder \
-       libqtappfw \
-       wayland-native \
-       wayland \
-       qtwayland \
-       qtwayland-native \
+    qtquickcontrols2 \
+    qlibhomescreen \
+    af-binder \
+    libqtappfw \
+    wayland-native \
+    wayland \
+    qtwayland \
+    qtwayland-native \
 "
 
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 inherit cmake_qt5 aglwgt
@@ -28,8 +29,8 @@ inherit cmake_qt5 aglwgt
 OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
 RDEPENDS_${PN} = " \
-       libqtappfw \
-       libafbwsc \
-       qlibhomescreen \
-       agl-service-voice-high-capabilities \
+    libqtappfw \
+    libafbwsc \
+    qlibhomescreen \
+    agl-service-voice-high-capabilities \
 "
index 7aba600..7c7d405 100644 (file)
@@ -7,23 +7,25 @@ LICENSE     = "Apache-2.0 & BSD"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://app/cluster-gauges.qml;beginline=9;endline=48;md5=54187d50b29429abee6095fe8b7c1a78"
 
+DEPENDS = " \
+    qtquickcontrols2 qtwebsockets libqtappfw glib-2.0 \
+    wayland-native wayland qtwayland qtwayland-native \
+"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-dashboard;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 qtwebsockets libqtappfw glib-2.0 \
-           wayland-native wayland qtwayland qtwayland-native"
-
 inherit pkgconfig cmake_qt5 aglwgt
 
 RDEPENDS_${PN} += " \
-       qtquickcontrols \
-       qtquickcontrols-qmlplugins \
-       qtquickcontrols2 \
-       qtquickcontrols2-qmlplugins \
-       libqtappfw \
-       agl-service-signal-composer \
+    qtquickcontrols \
+    qtquickcontrols-qmlplugins \
+    qtquickcontrols2 \
+    qtquickcontrols2-qmlplugins \
+    libqtappfw \
+    agl-service-signal-composer \
 "
index ca18d02..4366bd5 100644 (file)
@@ -7,23 +7,23 @@ LICENSE     = "Apache-2.0 & BSD"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://app/cluster-gauges.qml;beginline=10;endline=49;md5=54187d50b29429abee6095fe8b7c1a78"
 
+DEPENDS = "qtquickcontrols2 qtwebsockets"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-gauges;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 qtwebsockets"
-
 inherit pkgconfig cmake_qt5 aglwgt
 
 RDEPENDS_${PN} += " \
-       qtquickcontrols \
-       qtquickcontrols-qmlplugins \
-       qtquickcontrols2 \
-       qtquickcontrols2-qmlplugins \
-       qtwebsockets \
-       qtwebsockets-qmlplugins \
-       kms-conf \
+    qtquickcontrols \
+    qtquickcontrols-qmlplugins \
+    qtquickcontrols2 \
+    qtquickcontrols2-qmlplugins \
+    qtwebsockets \
+    qtwebsockets-qmlplugins \
+    kms-conf \
 "
index a698428..86c2f79 100644 (file)
@@ -6,20 +6,22 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0 & MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=374fee6a7817f1e1a5a7bfb7b7989553"
 
+DEPENDS = " \
+    wayland wayland-native \
+    gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
+"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "wayland wayland-native \
-           gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
-
 inherit cmake pkgconfig aglwgt
 
 RDEPENDS_${PN} += " \
-       gstreamer1.0-plugins-base \
-       gstreamer1.0-plugins-good \
-       gstreamer1.0-plugins-bad \
+    gstreamer1.0-plugins-base \
+    gstreamer1.0-plugins-good \
+    gstreamer1.0-plugins-bad \
 "
index 9c97596..a0fde07 100644 (file)
@@ -7,22 +7,24 @@ LICENSE     = "Apache-2.0 & MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://app/surface.hpp;beginline=5;endline=21;md5=5351c531a191f0e3463aafcd0a6a00a3"
 
+DEPENDS = " \
+    wayland wayland-native \
+    qtwayland qtwayland-native \
+    qtquickcontrols2 qtwebsockets qtbase qtdeclarative \
+    gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
+"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-qt-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "wayland wayland-native \
-           qtwayland qtwayland-native \
-           qtquickcontrols2 qtwebsockets qtbase qtdeclarative \
-           gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
-
 inherit cmake_qt5 pkgconfig aglwgt
 
 RDEPENDS_${PN} += " \
-       gstreamer1.0-plugins-base \
-       gstreamer1.0-plugins-good \
-       gstreamer1.0-plugins-bad \
+    gstreamer1.0-plugins-base \
+    gstreamer1.0-plugins-good \
+    gstreamer1.0-plugins-bad \
 "
index f19eb1f..64031d5 100644 (file)
@@ -6,18 +6,18 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
+DEPENDS = "qtquickcontrols2 qttools-native libqtappfw"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 qttools-native libqtappfw"
-
 inherit qmake5 aglwgt
 
 RDEPENDS_${PN} += " \
-       libqtappfw \
-       agl-service-signal-composer \
+    libqtappfw \
+    agl-service-signal-composer \
 "
index 92c2458..2940378 100644 (file)
@@ -5,33 +5,34 @@ LICENSE     = "Apache-2.0"
 SECTION     = "apps"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS = "\
-        qtbase \
-        qtdeclarative \
-        qtquickcontrols2 \
-        agl-service-homescreen \
-        agl-service-weather \
-        libqtappfw \
-        libhomescreen \
-        libafb-helpers-qt \
-        wayland-native \
-        wayland \
-        qtwayland \
-        qtwayland-native \
+DEPENDS = " \
+    qtbase \
+    qtdeclarative \
+    qtquickcontrols2 \
+    agl-service-homescreen \
+    agl-service-weather \
+    libqtappfw \
+    libhomescreen \
+    libafb-helpers-qt \
+    wayland-native \
+    wayland \
+    qtwayland \
+    qtwayland-native \
 "
 
-inherit qmake5 systemd pkgconfig aglwgt
+PV      = "1.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV      = "1.0+git${SRCPV}"
 S       = "${WORKDIR}/git/"
 
+inherit qmake5 systemd pkgconfig aglwgt
+
 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
 OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
 RDEPENDS_${PN} += " \
-        libqtappfw \
+    libqtappfw \
 "
index 2094652..ed2cce7 100644 (file)
@@ -6,17 +6,20 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
+DEPENDS = " \
+    qtquickcontrols2 \
+    libhomescreen \
+    qttools-native \
+    libqtappfw \
+"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 libhomescreen \
-            qttools-native \
-            libqtappfw"
+inherit qmake5 aglwgt
 
 RDEPENDS_${PN} = "agl-service-hvac libqtappfw"
-
-inherit qmake5 aglwgt
index 5b1de01..1f2117e 100644 (file)
@@ -17,12 +17,13 @@ DEPENDS = "\
         qtwayland-native \
 "
 
-inherit qmake5 systemd pkgconfig aglwgt
+PV      = "1.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV      = "1.0+git${SRCPV}"
 S       = "${WORKDIR}/git/"
 
+inherit qmake5 systemd pkgconfig aglwgt
+
 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
index 08990dc..aa80936 100644 (file)
@@ -6,19 +6,20 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
+DEPENDS = " \
+    qtquickcontrols2 \
+    qtwebsockets \
+    libqtappfw \
+    libhomescreen \
+"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 \
-            qtwebsockets \
-            libqtappfw \
-            libhomescreen \
-"
-
 inherit qmake5 aglwgt
 
 RDEPENDS_${PN} += "agl-service-mediaplayer libqtappfw"
index fbdff55..f440ca8 100644 (file)
@@ -6,18 +6,19 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
+DEPENDS = " \
+    qtquickcontrols2 \
+    libqtappfw \
+    libhomescreen \
+"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/messaging;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 \
-            libqtappfw \
-            libhomescreen \
-"
-
 inherit qmake5 aglwgt
 
 RDEPENDS_${PN} += "agl-service-bluetooth-map libqtappfw"
index 930e792..2ccd111 100644 (file)
@@ -6,23 +6,24 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+DEPENDS = " \
+    qtquickcontrols2 \
+    qtwebsockets \
+    libafb-helpers-qt \
+"
 
-PV = "1.0+git${SRCPV}"
-S  = "${WORKDIR}/git"
+PROVIDES += "virtual/mixer"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 \
-            qtwebsockets \
-            libafb-helpers-qt \
-"
+PV = "1.0+git${SRCPV}"
 
-RDEPENDS_${PN} += "agl-service-audiomixer"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
-PROVIDES += "virtual/mixer"
-RPROVIDES_${PN} += "virtual/mixer"
+S  = "${WORKDIR}/git"
 
 inherit cmake_qt5 aglwgt
 
 OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+
+RDEPENDS_${PN} = "agl-service-audiomixer"
+RPROVIDES_${PN} += "virtual/mixer"
index 98cd526..79d96a0 100644 (file)
@@ -6,10 +6,11 @@ SECTION     = "apps"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS += "qtquickcontrols2 \
-            qlibhomescreen \
-            qtlocation \
-            libqtappfw \
+DEPENDS = " \
+    qtquickcontrols2 \
+    qlibhomescreen \
+    qtlocation \
+    libqtappfw \
 "
 
 PV = "1.0+git${SRCPV}"
@@ -21,12 +22,13 @@ S = "${WORKDIR}/git"
 
 inherit qmake5 aglwgt pkgconfig
 
-RDEPENDS_${PN} += "qtlocation \
-                   flite \
-                   libqtappfw \
-                   openjtalk \
-                   gstreamer1.0 \
-                   ondemandnavi-config \
+RDEPENDS_${PN} += " \
+    qtlocation \
+    flite \
+    libqtappfw \
+    openjtalk \
+    gstreamer1.0 \
+    ondemandnavi-config \
 "
 
 RPROVIDES_${PN} = "virtual/navigation"
index 2942bf0..55d1142 100644 (file)
@@ -6,10 +6,12 @@ SECTION     = "apps"
 LICENSE          = "GPLv2"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=4ee23c52855c222cba72583d301d2338"
 
-DEPENDS += "qtbase json-c \
-            libhomescreen \
-            libqtappfw \
-           "
+DEPENDS = " \
+    qtbase \
+    json-c \
+    libhomescreen \
+    libqtappfw \
+"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
@@ -18,4 +20,4 @@ S = "${WORKDIR}/git"
 
 inherit cmake_qt5 pkgconfig aglwgt
 
-RDEPENDS_${PN} =  "qtbase libqtappfw"
+RDEPENDS_${PN} = "qtbase libqtappfw"
index d2e8e63..0965eb9 100644 (file)
@@ -11,13 +11,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://include/mapbox/recursive_wrapper.hpp;beginline=4;endline=13;md5=cd3341aae76c0cf8345935abd20f0051 \
 "
 
-DEPENDS += "qtbase \
-            qtquickcontrols2 \
-            qlibhomescreen \
-            qtlocation \
-            libqtappfw \
-            wayland-native \
-            qtwayland-native \
+DEPENDS = " \
+    qtbase \
+    qtquickcontrols2 \
+    qlibhomescreen \
+    qtlocation \
+    libqtappfw \
+    wayland-native \
+    qtwayland-native \
 "
 
 PV = "1.0+git${SRCPV}"
@@ -29,8 +30,9 @@ S = "${WORKDIR}/git"
 
 inherit qmake5 aglwgt pkgconfig
 
-RDEPENDS_${PN} += "qtlocation \
-                   ondemandnavi-config \
-                   agl-service-navigation \
-                   libqtappfw \
+RDEPENDS_${PN} += " \
+    qtlocation \
+    ondemandnavi-config \
+    agl-service-navigation \
+    libqtappfw \
 "
index 5278aaf..32a7a2d 100644 (file)
@@ -6,13 +6,13 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
+DEPENDS = "qtquickcontrols2 libhomescreen qlibhomescreen"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/onscreenapp;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 libhomescreen qlibhomescreen"
-
 inherit qmake5 aglwgt
index dd86722..41ca0e6 100644 (file)
@@ -6,19 +6,24 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+DEPENDS = " \
+    qtquickcontrols2 \
+    libqtappfw \
+    libhomescreen \
+    gstreamer1.0 \
+"
 
 PV = "1.0+git${SRCPV}"
-S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 \
-            libqtappfw \
-            libhomescreen \
-            gstreamer1.0 \
-"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
 
 inherit qmake5 aglwgt
 
-RDEPENDS_${PN} += "agl-service-telephony agl-service-bluetooth-pbap libqtappfw"
+RDEPENDS_${PN} += " \
+    agl-service-telephony \
+    agl-service-bluetooth-pbap \
+    libqtappfw \
+"
index e9e8b2b..605c4ce 100644 (file)
@@ -14,15 +14,15 @@ S = "${WORKDIR}/git/"
 
 inherit qmake5
 
-FILES_${PN} += "${OE_QMAKE_PATH_QML}/QtQuick/Controls.2/AGL/*"
-
-RDEPENDS_${PN} += " \
-       qtquickcontrols-qmlplugins \
-       qtquickcontrols2-qmlplugins \
-       qtsvg-plugins \
-"
-
 do_install_append_class-target() {
     install -d ${D}/${sysconfdir}/afm/unit.env.d
     echo "QT_QUICK_CONTROLS_STYLE=AGL" > ${D}${sysconfdir}/afm/unit.env.d/qtquickcontrols2-style
 }
+
+FILES_${PN} += "${OE_QMAKE_PATH_QML}/QtQuick/Controls.2/AGL/*"
+
+RDEPENDS_${PN} += " \
+    qtquickcontrols-qmlplugins \
+    qtquickcontrols2-qmlplugins \
+    qtsvg-plugins \
+"
index 0a432db..faab221 100644 (file)
@@ -17,7 +17,7 @@ inherit qmake5
 FILES_${PN} += "${OE_QMAKE_PATH_QML}/AGL/Demo/Controls/*"
 
 RDEPENDS_${PN} += " \
-       qtquickcontrols-qmlplugins \
-       qtquickcontrols2-qmlplugins \
-       qtsvg-plugins \
+    qtquickcontrols-qmlplugins \
+    qtquickcontrols2-qmlplugins \
+    qtsvg-plugins \
 "
index cba376c..5d0b9fb 100644 (file)
@@ -6,6 +6,10 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0 & GPLv2+"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
+DEPENDS = "qtquickcontrols2 rtl-sdr libhomescreen libqtappfw"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=https;branch=${AGL_BRANCH} \
            file://presets-ALS.conf \
            file://presets-CES.conf \
@@ -13,13 +17,8 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=https;bra
 "
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS = "qtquickcontrols2 rtl-sdr"
-DEPENDS += "libhomescreen libqtappfw"
-
 inherit qmake5 aglwgt
 
 # ALS, CES, FOSDEM available
index 6486b03..24ab47a 100644 (file)
@@ -6,22 +6,26 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
+DEPENDS = " \
+    libqtappfw \
+    qtquickcontrols2 \
+    qt-qrcode \
+    libhomescreen \
+    qtvirtualkeyboard \
+"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "libqtappfw qtquickcontrols2 qt-qrcode"
-DEPENDS += "libhomescreen qtvirtualkeyboard"
+inherit qmake5 aglwgt
 
-# runtime dependencies
 RDEPENDS_${PN} += " \
-       qt-qrcode \
-       agl-service-bluetooth \
-       agl-service-network \
-       libqtappfw \
+    qt-qrcode \
+    agl-service-bluetooth \
+    agl-service-network \
+    libqtappfw \
 "
-
-inherit qmake5 aglwgt
index 19c9fd6..9b96c86 100644 (file)
@@ -6,20 +6,21 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
+DEPENDS = " \
+    qtquickcontrols2 \
+    qtwebsockets \
+    qtcharts \
+    libqtappfw \
+    libhomescreen \
+"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/taskmanager;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 \
-            qtwebsockets \
-            qtcharts \
-            libqtappfw \
-            libhomescreen \
-"
-
 inherit qmake5 aglwgt
 
 RDEPENDS_${PN} += "agl-service-taskmanager libqtappfw"
index 2c2ee17..5f8a464 100644 (file)
@@ -6,20 +6,20 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
+DEPENDS = "glib-2.0 mosquitto"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-telematics-demo-recorder;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AUTOREV}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS = "glib-2.0 mosquitto"
-
 inherit cmake aglwgt
 
 RDEPENDS_${PN} += " \
-       agl-service-can-low-level \
-       agl-service-gps \
-       agl-service-network \
-       libmosquitto1 \
+    agl-service-can-low-level \
+    agl-service-gps \
+    agl-service-network \
+    libmosquitto1 \
 "
index 670ca8b..794b2de 100644 (file)
@@ -6,21 +6,23 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0 & MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=374fee6a7817f1e1a5a7bfb7b7989553"
 
+DEPENDS = " \
+    waltham wayland wayland-native \
+    gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
+"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/waltham-receiver.git;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "waltham wayland wayland-native \
-           gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
-
 inherit cmake pkgconfig aglwgt
 
 RDEPENDS_${PN} += " \
-       gstreamer1.0-plugins-base \
-       gstreamer1.0-plugins-good \
-       gstreamer1.0-plugins-bad \
-       waltham \
+    gstreamer1.0-plugins-base \
+    gstreamer1.0-plugins-good \
+    gstreamer1.0-plugins-bad \
+    waltham \
 "