Add now required pkgconfig inherit to restored app recipes
authorScott Murray <scott.murray@konsulko.com>
Thu, 24 Feb 2022 17:42:52 +0000 (12:42 -0500)
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>
Wed, 13 Apr 2022 13:31:22 +0000 (13:31 +0000)
The pkgconfig class is no longer automatically inherited via
dependencies in upstream poky, add the now required explicit
inherit in the restored recipes for the mediaplayer, radio,
phone, and messaging apps so they will build.

Bug-AGL: SPEC-3819

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I852ca9f38774e654265f3d09099bf7de60220330

recipes-demo/mediaplayer/mediaplayer_git.bb
recipes-demo/messaging/messaging_git.bb
recipes-demo/phone/phone_git.bb
recipes-demo/radio/radio_git.bb

index 7962f76..31d1020 100644 (file)
@@ -15,7 +15,7 @@ SRCREV  = "${AGL_APP_REVISION}"
 
 S  = "${WORKDIR}/git"
 
-inherit qmake5
+inherit qmake5 pkgconfig
 
 FILES:${PN} += "${datadir}/icons/"
 
index 47b3be8..0da2c9e 100644 (file)
@@ -15,7 +15,7 @@ SRCREV  = "${AGL_APP_REVISION}"
 
 S  = "${WORKDIR}/git"
 
-inherit qmake5
+inherit qmake5 pkgconfig
 
 FILES:${PN} += "${datadir}/icons/"
 
index 5e89af5..a5fa443 100644 (file)
@@ -15,7 +15,7 @@ SRCREV  = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
-inherit qmake5
+inherit qmake5 pkgconfig
 
 FILES:${PN} += "${datadir}/icons/ ${datadir}/sounds/"
 
index 326c411..b98d0fd 100644 (file)
@@ -19,7 +19,7 @@ SRCREV  = "${AGL_APP_REVISION}"
 
 S  = "${WORKDIR}/git"
 
-inherit qmake5
+inherit qmake5 pkgconfig
 
 # ALS, CES, FOSDEM available
 AGL_RADIO_PRESETS_LOCALE ?= "CES"