Fix FTBS in sllin 69/17869/1 6.0.2 flounder/6.0.2 flounder_6.0.2
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Mon, 12 Nov 2018 17:04:52 +0000 (18:04 +0100)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Mon, 12 Nov 2018 17:04:52 +0000 (18:04 +0100)
The file needs to be copied manually and not by the class itself.
Only the activation is handled automagically.

Change-Id: I524dde40e0017898e03a4c72cdf30a72a72a9f49
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-kernel/sllin/sllin.bb

index f3176a8..f7ffea9 100644 (file)
@@ -31,6 +31,8 @@ SYSTEMD_SERVICE_${PN} = "sllin-demo.service"
 do_install_append () {
        install -d 644 ${D}/${bindir}
        install -m 755 ${WORKDIR}/start_lin_demo.sh ${D}/${bindir}/start_lin_demo.sh
+       install -d ${D}${systemd_system_unitdir}
+       install -m 0644 ${WORKDIR}/sllin-demo.service ${D}${systemd_system_unitdir}/
 }
 
 FILES_${PN}_append = " ${bindir}/start_lin_demo.sh"