Merge the installation script to ces2017-demo 79/7879/3
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Mon, 26 Dec 2016 11:21:43 +0000 (20:21 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 27 Dec 2016 14:50:38 +0000 (14:50 +0000)
I divided the script of Navi, but I will do the merge.
With this change, all installations are done with one script.
This patch solves the problem that navigation can not be started.

Change-Id: I523b85cbee19531345c2e3fdaffc9c8c5f6b9c1b
Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
recipes-demo-hmi/navigation/poiapp/installNaviApps.sh [deleted file]
recipes-demo-hmi/navigation/poiapp_git.bb

index 777f98e..ef4b48d 100644 (file)
@@ -97,6 +97,11 @@ do_install_prepend() {
        /usr/bin/afm-util install radio.wgt
        /usr/bin/afm-util install settings.wgt
        /usr/bin/afm-util install navigation.wgt
+       /usr/bin/afm-util install poi.wgt
+       
+       #it's Workaround
+       cyad -s -k MANIFESTS -t allow -c User::App::navigation -u '*' -p 'http://tizen.org/privilege/internal/dbus'
+       cyad -s -k MANIFESTS -t allow -c User::App::poi -u '*' -p 'http://tizen.org/privilege/internal/dbus'
        EOF
 }
 
diff --git a/recipes-demo-hmi/navigation/poiapp/installNaviApps.sh b/recipes-demo-hmi/navigation/poiapp/installNaviApps.sh
deleted file mode 100644 (file)
index 50f27d6..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-/usr/bin/afm-util install poi.wgt
-
-#it's Workaround
-cyad -s -k MANIFESTS -t allow -c User::App::navigation -u '*' -p 'http://tizen.org/privilege/internal/dbus'
-cyad -s -k MANIFESTS -t allow -c User::App::poi -u '*' -p 'http://tizen.org/privilege/internal/dbus'
index 4575366..42707ba 100644 (file)
@@ -9,7 +9,6 @@ DEPENDS += " qtbase libdbus-c++ json-c \
 SRCREV="4e09ab88d0d97c59896ba66bf08a8e006e2af81a"
 SRC_URI="git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=new-layout \
          file://config.xml \
-         file://installNaviApps.sh \
 "
 
 RDEPENDS_${PN} = " navigation "
@@ -25,7 +24,6 @@ do_install_append() {
    install -d ${D}/usr/AGL/ces2017-demo
    install -m 0644 ${WORKDIR}/widget/poi.wgt ${D}/usr/AGL/ces2017-demo/
 
-   install -m 0755 ${WORKDIR}/installNaviApps.sh ${D}/usr/AGL/ces2017-demo/
 }
 
-FILES_${PN} += " /usr/AGL/ces2017-demo/poi.wgt /usr/AGL/ces2017-demo/installNaviApps.sh "
+FILES_${PN} += " /usr/AGL/ces2017-demo/poi.wgt "