[cef] Use bundled libwayland instead of the system lib 13/29113/2
authorRoger Zanoni <rzanoni@igalia.com>
Wed, 9 Aug 2023 13:26:18 +0000 (15:26 +0200)
committerRoger Zanoni <rzanoni@igalia.com>
Thu, 10 Aug 2023 07:05:13 +0000 (07:05 +0000)
For the M108 chromium milestone it would be possible to use the
use_system_libwayland and system_wayland_scanner_path gn args to make
the cef recipe use system wayland and wayland-native dependencies, but
those option got deprecated[1] in newer milestones and chormium defaults
to use the bundled wayland. The more maintainable approach is to use the
third party dependency instead of patching chromium build system.

[1]: https://chromium-review.googlesource.com/c/chromium/src/+/4030440

Bug-AGL: SPEC-4871

Signed-off-by: Roger Zanoni <rzanoni@igalia.com>
Change-Id: I7cb22fcfb1943d6765599544069a379088053a2c

recipes-wam/cef/cef_git.bb

index 1d1d83c..1a28324 100644 (file)
@@ -56,7 +56,7 @@ OUT_PATH = "${B}/out/Release_GN_${GN_TARGET_CPU}"
 DIST_PATH = "${OUT_PATH}/dist/cef-minimal_${GN_TARGET_CPU}"
 CEF_DATA_PATH = "${datadir}/cef"
 
-DEPENDS:append = " curl clang-native gperf-native wayland dbus libcxx compiler-rt libxkbcommon nss nss-native atk at-spi2-atk libdrm pango cairo virtual/egl qemu-native pciutils glib-2.0 pkgconfig-native pulseaudio"
+DEPENDS:append = " curl clang-native gperf-native dbus libcxx compiler-rt libxkbcommon nss nss-native atk at-spi2-atk libdrm pango cairo virtual/egl qemu-native pciutils glib-2.0 pkgconfig-native pulseaudio"
 
 do_sync[depends] += "depot-tools-wam-native:do_populate_sysroot"
 do_configure[depends] += "depot-tools-wam-native:do_populate_sysroot"
@@ -188,7 +188,7 @@ GN_DEFINES:append = " \
               ozone_platform_x11=false \
               use_system_minigbm=true \
               use_system_libdrm=true \
-              use_system_libwayland=true \
+              use_system_libwayland=false \
 "
 
 GN_DEFINES:append = " \