Merge remote-tracking branch 'agl/next' 62/24062/2
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Fri, 21 Feb 2020 15:21:35 +0000 (16:21 +0100)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Fri, 21 Feb 2020 15:30:36 +0000 (16:30 +0100)
* agl/next:
  packagegroup-agl-demo: replace udisks with udisk2
  vboxguestdrivers: upgrade to 6.1.2
  qtlocation: remove local patch
  Declare layer compatibility with zeus

Change-Id: Iac02f582ee0808329b343f80666d74fc5385af90

conf/layer.conf
recipes-platform/packagegroups/packagegroup-agl-demo.bb
recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch [deleted file]
recipes-qt/qt5/qtlocation_git.bbappend [deleted file]
recipes-support/vboxguestdrivers/vboxguestdrivers_6.1.2.bb [moved from recipes-support/vboxguestdrivers/vboxguestdrivers_6.0.10.bb with 73% similarity]

index 43a5be7..d62e61b 100644 (file)
@@ -9,4 +9,4 @@ BBFILE_COLLECTIONS += "agl-demo"
 BBFILE_PATTERN_agl-demo = "^${LAYERDIR}/"
 BBFILE_PRIORITY_agl-demo = "7"
 
-LAYERSERIES_COMPAT_agl-demo = "thud"
+LAYERSERIES_COMPAT_agl-demo = "zeus"
index 164684f..2bd16d7 100644 (file)
@@ -50,7 +50,7 @@ SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
 # AUDIO-OLD = "audiomanager"
 
 RDEPENDS_${PN} += "\
-    udisks \
+    udisks2 \
     ${SMARTDEVICELINK} \
     "
 
diff --git a/recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch b/recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch
deleted file mode 100644 (file)
index 164c9f0..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From 85df79b094d1097108a28424d6f9b3b76b3aee62 Mon Sep 17 00:00:00 2001
-From: Tasuku Suzuki <tasuku.suzuki@qt.io>
-Date: Thu, 8 Nov 2018 15:26:57 +0900
-Subject: [PATCH] Fix unstable rotation gesture
-
-Order of touch events are not sorted on some platform. When touch point
-1 and
-2 are swapped, map is rotated 180 degrees in a moment
-
-Change-Id: I9c308b805a6ca54519f26a9ff19217de7f947c17
-Reviewed-by: Paolo Angelelli <paolo.angelelli@qt.io>
----
- src/location/declarativemaps/qquickgeomapgesturearea.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/location/declarativemaps/qquickgeomapgesturearea.cpp b/src/location/declarativemaps/qquickgeomapgesturearea.cpp
-index c6f4b42..576aeee 100644
---- a/src/location/declarativemaps/qquickgeomapgesturearea.cpp
-+++ b/src/location/declarativemaps/qquickgeomapgesturearea.cpp
-@@ -1087,6 +1087,7 @@ void QQuickGeoMapGestureArea::update()
-     m_allPoints << m_touchPoints;
-     if (m_allPoints.isEmpty() && !m_mousePoint.isNull())
-         m_allPoints << *m_mousePoint.data();
-+    std::sort(m_allPoints.begin(), m_allPoints.end(), [](const QTouchEvent::TouchPoint &tp1, const QTouchEvent::TouchPoint &tp2) { return tp1.id() < tp2.id(); });
-     touchPointStateMachine();
--- 
-2.7.4
-
diff --git a/recipes-qt/qt5/qtlocation_git.bbappend b/recipes-qt/qt5/qtlocation_git.bbappend
deleted file mode 100644 (file)
index e0f3a6b..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-
-SRC_URI += " \
-    file://0001-Fix-unstable-rotation-gesture.patch \
-"
@@ -13,18 +13,21 @@ VBOX_NAME = "VirtualBox-${PV}"
 
 SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/${VBOX_NAME}.tar.bz2 \
     file://Makefile.utils \
-    "
-SRC_URI[md5sum] = "8428f7e27b244803df180213bc5d4a68"
-SRC_URI[sha256sum] = "5236148a93267478fb6d306f6343aa9587d3f90f437f54c7b3485bd9d538d2f8"
+"
+SRC_URI[md5sum] = "f4f42fd09857556b04b803fb99cc6905"
+SRC_URI[sha256sum] = "4326576e8428ea3626194fc82646347576e94c61f11d412a669fc8a10c2a1e67"
 
 S = "${WORKDIR}/vbox_module"
 
 export BUILD_TARGET_ARCH="${ARCH}"
 export BUILD_TARGET_ARCH_x86-64="amd64"
 
-EXTRA_OEMAKE += "KERN_DIR='${WORKDIR}/${KERNEL_VERSION}/build' all"
+EXTRA_OEMAKE += "KERN_DIR='${WORKDIR}/${KERNEL_VERSION}/build' KBUILD_VERBOSE=1"
 
-addtask export_sources before do_patch after do_unpack
+# otherwise 5.2.22 builds just vboxguest
+MAKE_TARGETS = "all"
+
+addtask export_sources after do_patch before do_configure
 
 do_export_sources() {
     mkdir -p "${S}"
@@ -40,12 +43,15 @@ do_export_sources() {
 }
 
 do_configure_prepend() {
+    # vboxguestdrivers/5.2.6-r0/vbox_module/vboxguest/Makefile.include.header:99: *** The variable KERN_DIR must be a kernel build folder and end with /build without a trailing slash, or KERN_VER must be set.  Stop.
+    # vboxguestdrivers/5.2.6-r0/vbox_module/vboxguest/Makefile.include.header:108: *** The kernel build folder path must end in <version>/build, or the variable KERN_VER must be set.  Stop.
     mkdir -p ${WORKDIR}/${KERNEL_VERSION}
     ln -snf ${STAGING_KERNEL_DIR} ${WORKDIR}/${KERNEL_VERSION}/build
 }
 
 # compile and install mount utility
-do_compile_append() {
+do_compile() {
+    oe_runmake all
     oe_runmake 'LD=${CC}' 'LDFLAGS=${LDFLAGS}' -C ${S}/utils
     if ! [ -e vboxguest.ko -a -e vboxsf.ko -a -e vboxvideo.ko ] ; then
         echo "ERROR: One of vbox*.ko modules wasn't built"