homescreen: Fix offscreen navigation guide 55/9455/3
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Mon, 22 May 2017 14:37:35 +0000 (23:37 +0900)
committerNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Tue, 23 May 2017 00:24:04 +0000 (09:24 +0900)
For ALS demo, fix the issue that navigation guide stops on off screen.
This fix uses the following patch fixes.
https://gerrit.automotivelinux.org/gerrit/#/c/9255/

Change-Id: I2088f16764b4ec79ff02ed7932b029357c1c2a61
Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
recipes-demo-hmi/homescreen/homescreen/fix-offscreen-navi-gid.patch [new file with mode: 0644]
recipes-demo-hmi/homescreen/homescreen_git.bb

diff --git a/recipes-demo-hmi/homescreen/homescreen/fix-offscreen-navi-gid.patch b/recipes-demo-hmi/homescreen/homescreen/fix-offscreen-navi-gid.patch
new file mode 100644 (file)
index 0000000..659045a
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/WindowManager/src/windowmanager.cpp b/WindowManager/src/windowmanager.cpp
+index 02bc392..9094115 100644
+--- a/WindowManager/src/windowmanager.cpp
++++ b/WindowManager/src/windowmanager.cpp
+@@ -74,6 +74,7 @@ WindowManager::WindowManager(int displayId, QObject *parent) :
+     m_showLayers[3] = WINDOWMANAGER_LAYER_HOMESCREEN; /* HOMESCREEN is shwon by default */
+     m_keepApps.append(QString("mediaplayer@"));
++    m_keepApps.append(QString("navigation@"));
+ #endif
+     qDebug("-=[WindowManager]=-");
+ }
index e871e31..a266f43 100644 (file)
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c9
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http \
            file://0001-Hack-to-resolve-the-media-player-doesn-t-play-next.patch \
+           file://fix-offscreen-navi-gid.patch \
            file://homescreen.pc.in \
            file://dbus-homescreen.conf.in"
 SRCREV  = "${AUTOREV}"