Disable sllin driver(using HVAC apps) debug log 37/18437/2 6.99.2 guppy/6.99.2 guppy_6.99.2
authorYuichi Kusakabe <yuichi.kusakabe@denso-ten.com>
Thu, 29 Nov 2018 17:57:01 +0000 (02:57 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 30 Nov 2018 13:40:20 +0000 (13:40 +0000)
[   30.042717] sllin: sllin_open() invoked
[   30.046603] sllin: Configured as MASTER
[   30.051508] sllin: Baudrate set to 9600
[   30.056332] sllin0 (uninitialized): sllin_kwthread started.
[   30.062486] sllin0: sllin_kthread <WAIT_EVENT>
[   31.153606] sllin0: sll_open() invoked
[   31.271843] can: raw protocol (rev 20170425)
[   31.276821] sllin0: sllin_kthread <WAKEUPED>
[   31.281124] sllin0: sllin_kthread: lin_state <00000000>
[   31.286370] sllin0: sllin_kwthread: NON-RTR SFF CAN frame, ID = 30
                dlc=0
[   31.286390] sllin0: sllin_kthread: SLSTATE finish
[   31.299297] sllin0: sllin_send_break() invoke.
[   31.305566] sllin0: Break sent.
[   31.308743] sllin0: sllin_kthread <WAIT_EVENT>

Change-Id: Id49951cb1ed570c99eb11d19298c1e5b57bcf13c
Signed-off-by: Yuichi Kusakabe <yuichi.kusakabe@denso-ten.com>
recipes-kernel/sllin/files/0001-Disable-sllin-driver-debug-log.patch [new file with mode: 0644]
recipes-kernel/sllin/sllin.bb

diff --git a/recipes-kernel/sllin/files/0001-Disable-sllin-driver-debug-log.patch b/recipes-kernel/sllin/files/0001-Disable-sllin-driver-debug-log.patch
new file mode 100644 (file)
index 0000000..99d6183
--- /dev/null
@@ -0,0 +1,27 @@
+From 04ffb4b8f828c19e914987e271aaf3aa7eab28bf Mon Sep 17 00:00:00 2001
+From: Yuichi Kusakabe <yuichi.kusakabe@denso-ten.com>
+Date: Thu, 29 Nov 2018 22:12:00 +0900
+Subject: [PATCH] Disable sllin driver debug log
+
+Signed-off-by: Yuichi Kusakabe <yuichi.kusakabe@denso-ten.com>
+---
+ sllin/sllin.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/sllin/sllin.c b/sllin/sllin.c
+index 77b2cb8..133d6e9 100644
+--- a/sllin/sllin.c
++++ b/sllin/sllin.c
+@@ -41,7 +41,9 @@
+  * Funded by:  Volkswagen Group Research
+  */
++#if 0
+ #define DEBUG                 1 /* Enables pr_debug() printouts */
++#endif
+ #include <linux/module.h>
+ #include <linux/moduleparam.h>
+-- 
+2.7.4
+
index f7ffea9..6213fd9 100644 (file)
@@ -16,6 +16,7 @@ SRC_URI_append = " \
        file://0001_update_makefile.patch;pnum=2 \
        file://0002_fix_null_operation_check.patch;pnum=2 \
        file://0003-Allow-recent-kernels-newer-4.11.x-to-build.patch;pnum=2 \
+       file://0001-Disable-sllin-driver-debug-log.patch;pnum=2 \
        file://sllin-demo.service \
        file://start_lin_demo.sh \
 "