agl-service-radio_git: Enable Kingfisher radio support for M3ULCB 21/12921/3
authorScott Murray <scott.murray@konsulko.com>
Fri, 22 Dec 2017 01:25:43 +0000 (20:25 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 27 Dec 2017 20:47:05 +0000 (20:47 +0000)
Pass the HAVE_KINGFISHER flag to CMake when building for M3ULCB to
enable support of the Kingfisher board's Si4689 radio.

Change-Id: Ib6d97a93402dbc6e555c999c77fea6b7ee20a1f6
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/agl-service-radio/agl-service-radio_git.bb

index 46dc48a..8f60c2e 100644 (file)
@@ -21,6 +21,8 @@ DEPENDS = "rtl-sdr glib-2.0 pulseaudio alsa-lib"
 
 inherit cmake aglwgt pkgconfig
 
+EXTRA_OECMAKE_append_m3ulcb = " -DHAVE_KINGFISHER=1"
+
 do_install_append() {
        if ${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', 'true', 'false', d)}; then
                install -d ${D}${systemd_user_unitdir}/afm-service-agl-service-radio@1.0.service.d