Create a virtual/mixer for the AGL mixer 19/14819/2
authorRonan Le Martret <ronan.lemartret@iot.bzh>
Tue, 26 Jun 2018 14:51:45 +0000 (16:51 +0200)
committerStéphane Desneux <stephane.desneux@iot.bzh>
Thu, 28 Jun 2018 19:14:49 +0000 (19:14 +0000)
Bug-AGL: SPEC-1520

Change-Id: I7e382d0b31dcdabb98a95d90bacf89f2ec03abe9
Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
recipes-demo-hmi/mixer/mixer_git.bb
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb

index ea33599..9ceb7d3 100644 (file)
@@ -10,8 +10,6 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;bra
 
 # 'legacy' version (eel_5.0.3) when 4A is not enabled
 SRCREV  = "eel_5.0.3"
-# 4A-aware mixer
-SRVREV_agl-audio-4a-framework = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
@@ -23,4 +21,6 @@ DEPENDS += "qtquickcontrols2 \
             qlibwindowmanager \
 "
 
+PROVIDES += "virtual/mixer"
+
 inherit qmake5 aglwgt
index c077287..637bbb2 100755 (executable)
@@ -42,7 +42,7 @@ AGL_APPS = " \
     dashboard \
     hvac \
     mediaplayer \
-    mixer \
+    virtual/mixer  \
     virtual/navigation \
     phone \
     poiapp \