html5-launcher: create recipe 77/22077/4
authorJacobo Aragunde Pérez <jaragunde@igalia.com>
Fri, 2 Aug 2019 10:44:53 +0000 (12:44 +0200)
committerJacobo Aragunde Pérez <jaragunde@igalia.com>
Mon, 26 Aug 2019 08:20:10 +0000 (10:20 +0200)
This recipe makes use of npm to install the JS dependencies and
also generate the wgt file.

Bug-AGL: SPEC-2401

Change-Id: I97557fa9193edabff611f98d12e54ec2463d4415
Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
recipes-demo-hmi/html5-launcher/html5-launcher_git.bb [new file with mode: 0644]

diff --git a/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb b/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb
new file mode 100644 (file)
index 0000000..ce8a1d1
--- /dev/null
@@ -0,0 +1,25 @@
+SUMMARY     = "AGL HTML5 Launcher Application"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-launcher/"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+  cd ${B}
+  npm install
+}
+
+do_aglwgt_package()  {
+  cd ${B}
+  npm run build
+}