libqtappfw: enable building mpd based mediaplayer support 75/27175/2
authorScott Murray <scott.murray@konsulko.com>
Mon, 14 Feb 2022 23:22:57 +0000 (18:22 -0500)
committerScott Murray <scott.murray@konsulko.com>
Tue, 15 Feb 2022 22:25:18 +0000 (22:25 +0000)
Update libqtappfw recipe to pull in libmpdclient dependency
for building the reworked mediaplayer support, and also add
a RRECOMMENDS definition that pulls in bluez5, connman, and
mpd to make the relationship more explicit.  The intent is
to split the libqtappfw-X libraries into separate packages
with some follow-on rework and have these dependencies be
more fine-grained at that point.

Bug-AGL: SPEC-4182

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: If7fcd57dab89a22dfee81017d0411854b1f16bda

recipes-demo/libqtappfw/libqtappfw_git.bb

index cc36e71..43d9e8a 100644 (file)
@@ -6,7 +6,14 @@ SECTION     = "libs"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS = "qtbase qtdeclarative glib-2.0 bluez-glib connman-glib"
+DEPENDS = " \
+    qtbase \
+    qtdeclarative \
+    glib-2.0 \
+    bluez-glib \
+    connman-glib \
+    libmpdclient \
+"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "5ef90db242ad29c9772f2237b477c58ef65545c7"
@@ -17,4 +24,6 @@ PV = "2.0+git${SRCPV}"
 
 inherit cmake_qt5 pkgconfig
 
+RRECOMMENDS:${PN} += "bluez5 connman mpd"
+
 BBCLASSEXTEND = "nativesdk"