Update Flutter demo images 41/28241/2
authorScott Murray <scott.murray@konsulko.com>
Thu, 8 Dec 2022 02:03:34 +0000 (11:03 +0900)
committerScott Murray <scott.murray@konsulko.com>
Sat, 10 Dec 2022 07:48:55 +0000 (07:48 +0000)
Changes:
- Split demo image feature definitions into an include file to
  allow reusing them, and pull into both the Qt and Flutter demo
  platform images.
- Remove packagegroup-agl-demo-platform dependencies from feature
  packagegroups so they will not break the Flutter images.
- Tweak Flutter cluster demo image to have KUKSA.val related
  package omission be controlled by the "agl-demo-preload"
  feature.
- Add the kuksa-vss-init package to the IVI services packagegroup
  so that the signal initialization expected by the Flutter cluster
  dashboard will always be done.  This covers the usecase of using
  the Flutter cluster with KUKSA.val on the IVI board.
- Add missing "agl-demo-preload" tweaks from the Qt demo platform
  image to the Flutter one.
- Tweak things to leave out the Weston terminal app from images
  build with the "agl-demo-preload" feature.
- Remove flutter-navigation and flutter-mediaplayer from the
  Flutter demo image for now, and add the messaging, phone, and
  radio Qt apps to fill out the list of apps for the demo.

Bug-AGL: SPEC-4636, SPEC-4637, SPEC-4639

Change-Id: I9cde89278f0191886152f765d4fb1a893c0ea2c1
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-platform/images/agl-cluster-demo-platform-flutter.bb
recipes-platform/images/agl-demo-features.inc [new file with mode: 0644]
recipes-platform/images/agl-ivi-demo-platform-flutter.bb
recipes-platform/images/agl-ivi-demo-platform.bb
recipes-platform/packagegroups/packagegroup-agl-demo-cluster-support.bb
recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb
recipes-platform/packagegroups/packagegroup-agl-graphical-weston_agldemo.inc
recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb

index 07555fd..a14560c 100644 (file)
@@ -2,28 +2,37 @@ SUMMARY = "Baseline Flutter Image for Release"
 
 LICENSE = "MIT"
 
-
 require recipes-platform/images/agl-image-weston.inc
 
+IMAGE_FEATURES += "splash package-management ssh-server-openssh"
+
+# Break out KUKSA.val packages, as demo unit configuration
+# points at KUKSA.val server on the IVI board instead of
+# running the full stack locally.
+IMAGE_KUKSA_PACKAGES = " \
+    kuksa-val \
+    kuksa-val-agl \
+    kuksa-dbc-feeder \
+    kuksa-vss-init \
+"
+
 # generic
 IMAGE_INSTALL:append = "\
     agl-compositor \
     agl-compositor-init \
-    packagegroup-agl-profile-graphical \
+    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
     \
-    kuksa-val \
-    kuksa-val-agl \
-    kuksa-dbc-feeder \
+    packagegroup-agl-profile-graphical \
+    packagegroup-agl-networking \
     \
-    kuksa-vss-init \
+    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "${IMAGE_KUKSA_PACKAGES}", d)} \
     simple-can-simulator \
     "
 
-# flutter
+# Flutter
 IMAGE_INSTALL:append = "\
-    weston-ini-conf-landscape \
-    \
-    flutter-cluster-dashboard-runtimerelease \
+    flutter-cluster-dashboard \
+    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "flutter-cluster-dashboard-conf-demo", "flutter-cluster-dashboard-conf", d)} \
     flutter-auto-runtimerelease \
     "
 
diff --git a/recipes-platform/images/agl-demo-features.inc b/recipes-platform/images/agl-demo-features.inc
new file mode 100644 (file)
index 0000000..beaad0b
--- /dev/null
@@ -0,0 +1,4 @@
+FEATURE_PACKAGES_agl-demo-preload = "packagegroup-agl-demo-preload"
+FEATURE_PACKAGES_agl-demo-cluster-support = "packagegroup-agl-demo-cluster-support"
+
+IMAGE_FEATURES += "${@bb.utils.filter("AGL_FEATURES", "agl-demo-preload agl-demo-cluster-support", d)}"
index 097c1fd..336ad3b 100644 (file)
@@ -2,9 +2,12 @@ require agl-image-ivi.bb
 
 DESCRIPTION = "AGL Flutter based Demo Platform image"
 
+require agl-demo-features.inc
+
 # add packages for demo platform (include demo apps) here
 IMAGE_INSTALL:append = " \
     packagegroup-agl-demo-platform-flutter \
     weston-ini-conf-flutter \
+    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "weston-terminal-conf", d)} \
 "
 
index d3bda6a..e82a474 100644 (file)
@@ -3,13 +3,11 @@ require agl-image-ivi.bb
 DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
 demos."
 
-FEATURE_PACKAGES_agl-demo-preload = "packagegroup-agl-demo-preload"
-FEATURE_PACKAGES_agl-demo-cluster-support = "packagegroup-agl-demo-cluster-support"
-
-IMAGE_FEATURES += "${@bb.utils.filter("AGL_FEATURES", "agl-demo-preload agl-demo-cluster-support", d)}"
+require agl-demo-features.inc
 
 # add packages for demo platform (include demo apps) here
 IMAGE_INSTALL:append = " \
     packagegroup-agl-demo-platform \
+    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "weston-terminal-conf", d)} \
 "
 
index 9836207..f64ea47 100644 (file)
@@ -10,7 +10,6 @@ PACKAGES = "\
 "
 
 RDEPENDS:${PN} += "\
-    packagegroup-agl-demo-platform \
     tbtnavi \
     kuksa-val-agl-demo-cluster \
 "
index 76bff18..4e290e3 100644 (file)
@@ -19,13 +19,14 @@ RDEPENDS:${PN} += "\
 AGL_FLUTTER_RUNTIME ?= "runtimerelease"
 
 AGL_APPS = " \
+    flutter-dashboard-${AGL_FLUTTER_RUNTIME} \ \
+    flutter-hvac-${AGL_FLUTTER_RUNTIME} \ \
+    ondemandnavi \
     settings \
     mediaplayer \
-    ondemandnavi \
-    flutter-dashboard-${AGL_FLUTTER_RUNTIME} \
-    flutter-hvac-${AGL_FLUTTER_RUNTIME} \
-    flutter-mediaplayer-${AGL_FLUTTER_RUNTIME} \
-    flutter-nav-${AGL_FLUTTER_RUNTIME} \
+    messaging \
+    phone \
+    radio \
     "
 
 RDEPENDS:${PN}:append = " \
index 2facd00..808c93c 100644 (file)
@@ -18,7 +18,6 @@ PACKAGES = " \
 #     the steering wheel used in the demo setup.
 #
 RDEPENDS:${PN} = "\
-    packagegroup-agl-demo-platform \
     demo-i2c-udev-conf \
     simple-can-simulator \
 "
index 8bcd63f..2b91c17 100644 (file)
@@ -2,5 +2,4 @@ RDEPENDS:${PN}:remove = "weston-init"
 
 RDEPENDS:${PN} += " \
                   agl-compositor-init \
-                  weston-terminal-conf \
                   "
index 6d2f654..2e6fff4 100644 (file)
@@ -11,6 +11,7 @@ RDEPENDS:${PN} += "\
     kuksa-val \
     kuksa-val-agl \
     kuksa-dbc-feeder \
+    kuksa-vss-init \
     agl-service-hvac \
     agl-service-audiomixer \
     "