meta-agl-demo: add recipes-most 11/5911/3
authorChristian Gromm <christian.gromm@microchip.com>
Thu, 23 Jun 2016 11:07:38 +0000 (13:07 +0200)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Wed, 6 Jul 2016 19:02:19 +0000 (21:02 +0200)
This patch adds the recipes needed to copy the applicatons from the
most-can-demo-bin folder of the staging area to  and the
/home/root directory. It is needed to run the MOST video demo and the
CAN application on the agl-demo-platform.

v2: Changed folder recipes-demo-hmi as per discussion in gerrit (jsmoeller)

Change-Id: I5de98416a4d32b794552a2e42d4e95129704db47
Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb [new file with mode: 0644]
recipes-demo-hmi/ALS2016-demo/vod_0.1.bb [new file with mode: 0644]

diff --git a/recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb b/recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb
new file mode 100644 (file)
index 0000000..1cca96c
--- /dev/null
@@ -0,0 +1,23 @@
+DESCRIPTION = "CAN-LIN Application"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+PR = "r0"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/most-can-demo-bin;protocol=https"
+
+S = "${WORKDIR}/git"
+SRCREV = "cd6e46d117934139efdf5fac33fbeb59b66e45b6"
+
+do_configure() {
+        echo ""
+}
+
+do_compile() {
+        echo ""
+}
+
+do_install() {
+        install -m 0755 -d ${D}${bindir}
+        install -m 0644 ${S}/OptoLyzerMoccaApp ${D}${bindir}
+}
+
diff --git a/recipes-demo-hmi/ALS2016-demo/vod_0.1.bb b/recipes-demo-hmi/ALS2016-demo/vod_0.1.bb
new file mode 100644 (file)
index 0000000..670e680
--- /dev/null
@@ -0,0 +1,30 @@
+DESCRIPTION = "Video on demand"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+PR = "r0"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/most-can-demo-bin;protocol=https"
+
+S = "${WORKDIR}/git"
+SRCREV = "cd6e46d117934139efdf5fac33fbeb59b66e45b6"
+
+do_configure() {
+        echo ""
+}
+
+do_compile() {
+        echo ""
+}
+
+do_install() {
+        install -m 0755 -d ${D}${bindir} ${D}${base_dir}/home/root ${D}${docdir}/video-on-demand
+        install -m 0644 ${S}/NetworkManager ${D}${bindir}
+        install -m 0644 ${S}/VideoOnDemand ${D}${bindir}
+        install -m 0644 ${S}/vod-client ${D}${bindir}
+       install -m 0644 ${S}/config-agl.xml ${D}${base_dir}/home/root
+       install -m 0644 ${S}/i2c-slim-amplifier.script ${D}${base_dir}/home/root
+       install -m 0644 ${S}/i2c-uda1388-v2.script ${D}${base_dir}/home/root
+#        install -m 0644 ${WORKDIR}/README.txt ${D}${docdir}/video-on-demand
+}
+FILES_${PN} += "/home/root*"
+