Navigation update for AMM 2017 demos 35/8335/1
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Thu, 19 Jan 2017 15:40:08 +0000 (00:40 +0900)
committerNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Mon, 23 Jan 2017 15:12:15 +0000 (00:12 +0900)
This patch includes the following correspondence.
Partial fix : Fix SPEC-364 SDK build issue.
For AMM demo : Enable japanese guide voice.
Adding JP map download script.

Change-Id: I4c58a6e4630460ff2f30abb73519aaaab0e2b7b5
Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
recipes-demo-hmi/navigation/navigation/config.xml [deleted file]
recipes-demo-hmi/navigation/navigation/download_mapdata_jp.sh [new file with mode: 0755]
recipes-demo-hmi/navigation/navigation/download_mapdata_uk.sh [moved from recipes-demo-hmi/navigation/navigation/download_mapdata.sh with 100% similarity]
recipes-demo-hmi/navigation/navigation_0.0.7.bb [deleted file]
recipes-demo-hmi/navigation/navigation_git.bb

diff --git a/recipes-demo-hmi/navigation/navigation/config.xml b/recipes-demo-hmi/navigation/navigation/config.xml
deleted file mode 100755 (executable)
index 954974d..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<widget xmlns="http://www.w3.org/ns/widgets" id="navigation" version="0.1">
-  <name>Navigation</name>
-  <icon src="navigation.png"/>
-  <content src="navi" type="application/x-executable"/>
-  <description>NAVIGATION App</description>
-  <author>AISIN AW</author>
-  <license>GPL</license>
-</widget>
diff --git a/recipes-demo-hmi/navigation/navigation/download_mapdata_jp.sh b/recipes-demo-hmi/navigation/navigation/download_mapdata_jp.sh
new file mode 100755 (executable)
index 0000000..15120f8
--- /dev/null
@@ -0,0 +1,61 @@
+#!/bin/sh
+#
+# AGL Navigation mapdata download scripts
+#
+
+#--------------------------------------------------------------
+help()
+{
+bn=`basename $0`
+cat << EOF
+usage
+host: sudo $bn 'target_rootfs_path/'
+target : $bn /
+EOF
+
+}
+#-check para-------------------------------------------------------
+shift `expr $OPTIND - 1`
+
+if [ $# != 1  ]; then
+        help
+        exit
+fi
+
+rootfs=$1
+
+#----------------------------------------------------------------
+
+# check the if root? ------------------------------
+userid=`id -u`
+if [ $userid -ne "0" ]; then
+        echo "you're not root? run with sudo"
+        exit
+fi
+
+if [ ! -e $1 ]; then
+       echo "rootfs:$1 not found"
+       exit
+fi
+
+if [ ! -f $HOME/navi_data.tar.gz ]; then
+       echo "no map data"
+       echo "start downloading..."
+       wget --directory-prefix=$HOME http://agl.wismobi.com/data/japan_TR9/navi_data.tar.gz
+else
+       echo "use downloaded map data"
+fi
+
+mapdatadir=$rootfs/var/mapdata
+
+if [ ! -d $mapdatadir ]; then
+       echo "map data directory does not exist"
+       echo "create a directory" $mapdatadir
+       mkdir -p $mapdatadir
+else
+       echo "map data directory exists"
+fi
+
+tar xvzf $HOME/navi_data.tar.gz -C $mapdatadir
+sync
+echo "done.."
diff --git a/recipes-demo-hmi/navigation/navigation_0.0.7.bb b/recipes-demo-hmi/navigation/navigation_0.0.7.bb
deleted file mode 100755 (executable)
index 8f7e7a2..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-LICENSE="GPLv2"
-LIC_FILES_CHKSUM="file://LICENSE;md5=3595e9c703a847d990664d2b396a9df0 \
-                  file://COPYING;md5=947b2d60ca3872e172034438e9801200"
-
-DEPENDS =        "glib-2.0 freetype sqlite3 wayland zlib expat openssl virtual/libgles2 virtual/libgl virtual/egl wayland"
-#RDEPENDS_${PN} = "glib-2.0 freetype sqlite3 wayland zlib expat openssl libegl libwayland-egl"
-
-SRCREV="v0.0.7"
-SRC_URI="git://github.com/gpsnavi/gpsnavi.git"
-
-# To avoid C++ library link failure
-SECURITY_CFLAGS = ""
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
index 10c0288..2bdd1cc 100755 (executable)
@@ -1,20 +1,25 @@
+SUMMARY     = "AGL Reference Navigation application."
+DESCRIPTION = "This application provides the function of Navigation to AGL. "
+HOMEPAGE    = "http://agl.wismobi.com/"
+SECTION     = "apps"
+
 LICENSE="GPLv2"
 LIC_FILES_CHKSUM="file://LICENSE;md5=3595e9c703a847d990664d2b396a9df0 \
                   file://COPYING;md5=947b2d60ca3872e172034438e9801200"
 
 DEPENDS = " \
           glib-2.0 freetype sqlite3 wayland zlib expat openssl virtual/libgles2 virtual/libgl virtual/egl \
-          wayland libdbus-c++ zip-native \
+          wayland libdbus-c++ af-main \
           "
 
 RDEPENDS_${PN} = " flite openjtalk "
 
-SRCREV="1b7218335b5b7a5312e3611138c70c49a27a3b9f"
-SRC_URI="git://github.com/AGLExport/gpsnavi.git \
+SRCREV="3dc643168cfa8ea0028b53770351a1fa608265c1"
+SRC_URI="git://github.com/AGLExport/gpsnavi.git;branch=agl \
          file://flite.in \
          file://jtalk.in \
-         file://config.xml \
-         file://download_mapdata.sh \
+         file://download_mapdata_jp.sh \
+         file://download_mapdata_uk.sh \
 "
 
 # To avoid C++ library link failure
@@ -30,14 +35,10 @@ do_compile_prepend() {
 }
 
 do_install_append() {
-   mkdir -p ${WORKDIR}/widget
-   install -m 0644 ${WORKDIR}/config.xml ${WORKDIR}/widget
-   install -m 0755 ${D}/usr/bin/navi ${WORKDIR}/widget
-   zip -ju ${WORKDIR}/widget/navigation.wgt ${WORKDIR}/widget/navi ${WORKDIR}/widget/config.xml
-
    install -d ${D}/usr/AGL/apps
-   install -m 0644 ${WORKDIR}/widget/navigation.wgt ${D}/usr/AGL/apps/
-   install -m 0755 ${WORKDIR}/download_mapdata.sh ${D}/usr/AGL/apps/
+   install -m 0644 ${B}/navigation.wgt ${D}/usr/AGL/apps/
+   install -m 0755 ${WORKDIR}/download_mapdata_jp.sh ${D}/usr/AGL/apps/
+   install -m 0755 ${WORKDIR}/download_mapdata_uk.sh ${D}/usr/AGL/apps/
 
    install -d ${D}/var/mapdata
 }