html5-homescreen: Avoid autostart of launcher on qemu 17/25217/2
authorLorenzo Tilve <ltilve@igalia.com>
Tue, 8 Sep 2020 08:26:03 +0000 (10:26 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 8 Sep 2020 15:51:55 +0000 (15:51 +0000)
When launching automatically the html5-laucher from the html5-homescreen
using the sw compositing pipeline on qemu, a race condition is happening
that is breaking the UI.

This is removing this autostart of the launcher, which still can
be started manually, while the racing issues are fixed.

Bug-AGL: SPEC-3544

Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
Change-Id: Ic9e3dbf68d69d3042b0e850e63c7ff0c210cf1a4

recipes-demo-hmi/html5-homescreen/files/0001-Disable-autostart-of-launcher-webapp.patch [new file with mode: 0644]
recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb

diff --git a/recipes-demo-hmi/html5-homescreen/files/0001-Disable-autostart-of-launcher-webapp.patch b/recipes-demo-hmi/html5-homescreen/files/0001-Disable-autostart-of-launcher-webapp.patch
new file mode 100644 (file)
index 0000000..6a8efd7
--- /dev/null
@@ -0,0 +1,25 @@
+From 5112f934e4e5afca02467088d3c7008cbdc620d2 Mon Sep 17 00:00:00 2001
+From: Lorenzo Tilve <ltilve@igalia.com>
+Date: Mon, 7 Sep 2020 06:53:52 +0200
+Subject: [PATCH] Disable autostart of launcher webapp
+
+Change-Id: I2eabab3772e4e5eb457f2c47670448554e72d14a
+---
+ src/config.json | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/config.json b/src/config.json
+index fb94d9d..febbb21 100644
+--- a/src/config.json
++++ b/src/config.json
+@@ -18,7 +18,6 @@
+         }
+     ],
+     "background": "webapps-html5-background",
+-    "launch": "webapps-html5-launcher",
+     "network": {
+         "bluetooth": "fab fa-bluetooth-b",
+         "ethernet": "fas fa-network-wired",
+-- 
+2.28.0
+
index 37ca707..a44f72f 100644 (file)
@@ -8,6 +8,9 @@ PV      = "1.0+git${SRCPV}"
 S       = "${WORKDIR}/git/"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=${AGL_BRANCH}"
+
+SRC_URI_append_qemuall = " file://0001-Disable-autostart-of-launcher-webapp.patch"
+
 SRCREV = "${AGL_APP_REVISION}"
 
 DEPENDS = "nodejs-native"