agl-service-radio: Set appropriate sink if 4A is configured 65/12865/2
authorScott Murray <scott.murray@konsulko.com>
Thu, 21 Dec 2017 00:39:54 +0000 (19:39 -0500)
committerScott Murray <scott.murray@konsulko.com>
Thu, 21 Dec 2017 00:55:39 +0000 (19:55 -0500)
If 4A is enabled in DISTRO_FEATURES, add an extension conf file to add setting
PULSE_SINK to the systemd service unit.  This will direct the radio output
into the matching PulseAudio sink for the 4A Radio role.

Change-Id: Ic67f3bcf1bd64636813e426f4471e666d2c33938
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/agl-service-radio/agl-service-radio_git.bb
recipes-demo-hmi/agl-service-radio/files/set-4a-output-sink.conf [new file with mode: 0644]

index 0e913af..46dc48a 100644 (file)
@@ -8,7 +8,9 @@ LICENSE     = "Apache-2.0 & GPLv2+"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=https;branch=${AGL_BRANCH} \
+           file://set-4a-output-sink.conf \
+"
 SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
@@ -18,3 +20,12 @@ S  = "${WORKDIR}/git"
 DEPENDS = "rtl-sdr glib-2.0 pulseaudio alsa-lib"
 
 inherit cmake aglwgt pkgconfig
+
+do_install_append() {
+       if ${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', 'true', 'false', d)}; then
+               install -d ${D}${systemd_user_unitdir}/afm-service-agl-service-radio@1.0.service.d
+               install -m 0644 ${WORKDIR}/set-4a-output-sink.conf ${D}${systemd_user_unitdir}/afm-service-agl-service-radio@1.0.service.d/
+       fi
+}
+
+FILES_${PN} += "${systemd_user_unitdir}"
diff --git a/recipes-demo-hmi/agl-service-radio/files/set-4a-output-sink.conf b/recipes-demo-hmi/agl-service-radio/files/set-4a-output-sink.conf
new file mode 100644 (file)
index 0000000..c574ca1
--- /dev/null
@@ -0,0 +1,2 @@
+[Service]
+Environment=PULSE_SINK=alsa_output.Radio