Add demo low-can device mapping 98/23498/2
authorScott Murray <scott.murray@konsulko.com>
Sun, 29 Dec 2019 23:30:47 +0000 (18:30 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 30 Dec 2019 14:56:48 +0000 (14:56 +0000)
Rework the agl-demo-preload feature to specify a new demo-specific
PREFERRED_RPROVIDER for the new virtual/low-can-dev-mapping virtual
package. This enables using the sllin0 interface on the CES demo
setup as the low-speed interface.

Bug-AGL: SPEC-3076

Change-Id: I872137d8acb1f5ec5df9eac92f25953b28128b36
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
conf/include/agl-demo-preload.inc [new file with mode: 0644]
recipes-config/dev-mapping-demo/dev-mapping-demo/dev-mapping.conf.demo [new file with mode: 0644]
recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb [new file with mode: 0644]
templates/feature/agl-demo-preload/50_local.conf.inc

diff --git a/conf/include/agl-demo-preload.inc b/conf/include/agl-demo-preload.inc
new file mode 100644 (file)
index 0000000..a17d140
--- /dev/null
@@ -0,0 +1,4 @@
+DISTRO_FEATURES_append = " agl-demo-preload"
+
+# Use demo device mapping for low-can that enables sllin0
+PREFERRED_RPROVIDER_virtual/low-can-dev-mapping = "dev-mapping-demo"
diff --git a/recipes-config/dev-mapping-demo/dev-mapping-demo/dev-mapping.conf.demo b/recipes-config/dev-mapping-demo/dev-mapping-demo/dev-mapping.conf.demo
new file mode 100644 (file)
index 0000000..93b0a02
--- /dev/null
@@ -0,0 +1,6 @@
+; Default CAN device mapping
+; Format has to follow ini rules key="value", notice " around value.
+
+[CANbus-mapping]
+hs="can0"
+ls="sllin0"
diff --git a/recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb b/recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb
new file mode 100644 (file)
index 0000000..4a04ce1
--- /dev/null
@@ -0,0 +1,18 @@
+SUMMARY = "AGL demo device mapping configuration file"
+DESCRIPTION = "This provide default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in low-can binding for the AGL demo setup."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.demo"
+
+inherit allarch
+
+do_install() {
+    install -d ${D}${sysconfdir}
+    install -m 0644 ${WORKDIR}/dev-mapping.conf.demo ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES_${PN} = "virtual/low-can-dev-mapping"
index c7524e5..00ff3b7 100644 (file)
@@ -1 +1,2 @@
-DISTRO_FEATURES_append = " agl-demo-preload"
+#see meta-agl-demo/conf/include/agl-demo-preload.inc
+require conf/include/agl-demo-preload.inc