Change SRC_URI and SRCREV for ivi-demo-flutter-apps 41/28041/2
authorHritik Chouhan <hritikc3961@gmail.com>
Wed, 5 Oct 2022 19:18:43 +0000 (21:18 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sat, 8 Oct 2022 21:50:47 +0000 (21:50 +0000)
- Change SRC_URI to use the app repository on gerrit.
- Renamed recipes file name.

Bug-AGL: SPEC-4560

Change-Id: I2887e568e6a466836d68866ace0766c7ed7949d9
Signed-off-by: Hritik Chouhan <hritikc3961@gmail.com>
recipes-demo/flutter-dashboard/flutter-dashboard_git.bb [moved from recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb with 78% similarity]
recipes-demo/flutter-hvac/files/HVAC_config.yaml [moved from recipes-demo/flutter-hvac/files/hvac_config.yaml with 100% similarity]
recipes-demo/flutter-hvac/flutter-hvac_git.bb [moved from recipes-demo/flutter-hvac/flutter-app-hvac_git.bb with 69% similarity]
recipes-demo/flutter-mediaplayer/flutter-mediaplayer_git.bb [moved from recipes-demo/flutter-mediaplayer/flutter-app-mediaplayer_git.bb with 72% similarity]
recipes-demo/flutter-nav/flutter-nav_git.bb [moved from recipes-demo/flutter-nav/flutter-app-nav_git.bb with 83% similarity]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb

@@ -1,7 +1,7 @@
 SUMMARY = "Flutter Dashboard"
 DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
 
-HOMEPAGE = "https://github.com/hritik-chouhan/dashboard_for_recipe"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard"
 
 BUGTRACKER = "https://github.com/hritik-chouhan/dashboard_for_recipe/issues"
 
@@ -11,11 +11,11 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
 
 
-SRC_URI = "git://github.com/hritik-chouhan/dashboard_for_recipe.git;protocol=https;branch=main \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard;protocol=https;branch=${AGL_BRANCH} \
     file://dashboard_config.yaml \
     "
 
-SRCREV = "5b0e5cdc3ba8b00a7e53b46e8b3e656cd09822bb"
+SRCREV = "10945b8056eb2b228c156918a3505882a49a79b8"
 S = "${WORKDIR}/git"
 
 
@@ -1,7 +1,7 @@
 SUMMARY = "Flutter HVAC"
 DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
 
-HOMEPAGE = "https://github.com/hritik-chouhan/HVAC_dashboard"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-hvac"
 
 BUGTRACKER = "https://github.com/hritik-chouhan/HVAC_dashboard/issues"
 
@@ -11,11 +11,11 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
 
 
-SRC_URI = "git://github.com/hritik-chouhan/HVAC_dashboard.git;protocol=https;branch=main \
-    file://hvac_config.yaml \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-hvac;protocol=https;branch=${AGL_BRANCH} \
+    file://HVAC_config.yaml \
     "
 
-SRCREV = "892f09a82dd852b66416598c9ec47b3230c5d56c"
+SRCREV = "5559cdb261cfd3e69daa2349906f071dc2491c0d"
 S = "${WORKDIR}/git"
 
 inherit agl-app flutter-app
@@ -34,7 +34,7 @@ AGL_APP_NAME = "Flutter Hvac"
 
 do_install:append() {
     install -d ${D}${sysconfdir}/xdg/AGL
-    install -m 0644 ${WORKDIR}/hvac_config.yaml ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/HVAC_config.yaml ${D}${sysconfdir}/xdg/AGL/
 }
 
 FILES:${PN} += "${sysconfdir}/xdg/AGL"
@@ -1,7 +1,7 @@
 SUMMARY = "Flutter MediaPlayer app for IVI"
 DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux"
 
-HOMEPAGE = "https://github.com/hritik-chouhan/musicplayer"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-mediaplayer"
 
 BUGTRACKER = "https://github.com/hritik-chouhan/musicplayer/issues"
 
@@ -11,8 +11,8 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
 
 
-SRC_URI = "git://github.com/hritik-chouhan/musicplayer.git;protocol=https;branch=main"
-SRCREV = "45f9425552ec08a8706953c41aa25b0fc1a6fb57"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "735de5a38ea937ee13157f6ac594053ddb8b027b"
 S = "${WORKDIR}/git"
 
 inherit agl-app flutter-app
@@ -1,7 +1,7 @@
 SUMMARY = "Flutter Navigation app"
 DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
 
-HOMEPAGE = "https://github.com/hritik-chouhan/nav-app"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-navigation"
 
 BUGTRACKER = "https://github.com/hritik-chouhan/nav-app/issues"
 
@@ -11,10 +11,10 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
 
 
-SRC_URI = "git://github.com/hritik-chouhan/nav-app.git;protocol=https;branch=main \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-navigation;protocol=https;branch=${AGL_BRANCH} \
     file://nav_config.yaml \
     "
-SRCREV = "a6619ac0439f6dec728b9a3a094f1371ee00ce76"
+SRCREV = "53164c0441db946b4293f483a28b524ecdc91e30"
 S = "${WORKDIR}/git"
 
 MAPBOX_API_KEY ??= "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF"
index c40d0f6..2ab6882 100644 (file)
@@ -20,10 +20,10 @@ RDEPENDS:${PN} += "\
 AGL_APPS = " \
     hvac \
     dashboard \
-    flutter-app-dashboard \
-    flutter-app-hvac \
-    flutter-app-nav \
-    flutter-app-mediaplayer \
+    flutter-dashboard \
+    flutter-hvac \
+    flutter-nav \
+    flutter-mediaplayer \
     "
 
 RDEPENDS:${PN}:append = " \