navigation-demo: add navigation demo application recipe 47/12347/2
authorMatt Ranostay <matt.ranostay@konsulko.com>
Thu, 7 Dec 2017 04:30:42 +0000 (20:30 -0800)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 8 Dec 2017 15:13:13 +0000 (15:13 +0000)
Add alternative navigation package recipe that is based on the
qtlocation examples

Bug-AGL: SPEC-1157
Change-Id: I1ea85f74bc5a40a4d637dc583570df931f1f2810
Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
recipes-demo-hmi/navigation/navigation-demo_git.bb [new file with mode: 0644]

diff --git a/recipes-demo-hmi/navigation/navigation-demo_git.bb b/recipes-demo-hmi/navigation/navigation-demo_git.bb
new file mode 100644 (file)
index 0000000..75381d5
--- /dev/null
@@ -0,0 +1,31 @@
+SUMMARY     = "Navigation demo based on Qt examples"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/navigation"
+SECTION     = "apps"
+
+LICENSE     = "BSD-3-Clause & CC0v1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b6bbd37d85cd2b68082aa7be27853da1 \
+                    file://LICENSE.for_car_png;md5=65d3616852dbf7b1a6d4b53b00626032 \
+                   "
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/navigation;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+RPROVIDES_${PN} = "virtual/navigation"
+
+DEPENDS  += "qtquickcontrols2 \
+             virtual/libhomescreen \
+             qlibwindowmanager \
+             qtvirtualkeyboard \
+             qtlocation \
+            "
+
+RDEPENDS_${PN} = " \
+             agl-service-gps \
+             agl-service-geoclue \
+             agl-service-geofence \
+            "
+
+inherit qmake5 aglwgt