cannelloni: convert to bbappend and make it conditional 34/28534/1
authorDenys Dmytriyenko <denys@konsulko.com>
Tue, 28 Feb 2023 01:34:58 +0000 (01:34 +0000)
committerDenys Dmytriyenko <denys@konsulko.com>
Tue, 28 Feb 2023 01:34:58 +0000 (01:34 +0000)
cannelloni_git.bb was added to meta-agl-demo in 2020. And meta-networking
later added cannelloni_1.0.0.bb in 2021. Comparing the 2, it seems they are
mostly identical, but point to different SRCREVs, resulting in the following
error from yocto-check-layer:

INFO: test_signatures (common.CommonCheckLayer)
INFO:  ... FAIL
AssertionError: Adding layer meta-agl-demo changed signatures, basehash changed

Convert the recipe to bbappend and adjust SRCREV and PV conditionaly based on
"agldemo" AGL_FEATURES flag.

Bug-AGL: SPEC-4685
Change-Id: Ic7e53c9093d0936599f6205ef95a3a824c721bcc
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
recipes-connectivity/cannelloni/cannelloni/0001-Fix-compilation-on-latest-gcc-versions.patch [deleted file]
recipes-connectivity/cannelloni/cannelloni_%.bbappend [new file with mode: 0644]
recipes-connectivity/cannelloni/cannelloni_agldemo.inc [new file with mode: 0644]
recipes-connectivity/cannelloni/cannelloni_git.bb [deleted file]

diff --git a/recipes-connectivity/cannelloni/cannelloni/0001-Fix-compilation-on-latest-gcc-versions.patch b/recipes-connectivity/cannelloni/cannelloni/0001-Fix-compilation-on-latest-gcc-versions.patch
deleted file mode 100644 (file)
index b5e59e6..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-From f3b356b1ecd6c5401537f593ce373a5b76eb8a9d Mon Sep 17 00:00:00 2001
-From: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-Date: Tue, 17 Nov 2020 16:06:20 +0100
-Subject: [PATCH] Fix compilation on latest gcc versions
-
-Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
----
- CMakeLists.txt | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 51fa256..7e977d1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -6,7 +6,8 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
- # Options
- option(SCTP_SUPPORT "SCTP_SUPPORT" ON)
--set(CMAKE_CXX_FLAGS -Wall)
-+#set(CMAKE_CXX_FLAGS -Wall)
-+set(CMAKE_CXX_STANDARD 11)
- if(SCTP_SUPPORT)
-   include(FindSCTP)
diff --git a/recipes-connectivity/cannelloni/cannelloni_%.bbappend b/recipes-connectivity/cannelloni/cannelloni_%.bbappend
new file mode 100644 (file)
index 0000000..4619406
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'cannelloni_agldemo.inc', '', d)}
diff --git a/recipes-connectivity/cannelloni/cannelloni_agldemo.inc b/recipes-connectivity/cannelloni/cannelloni_agldemo.inc
new file mode 100644 (file)
index 0000000..c83d535
--- /dev/null
@@ -0,0 +1,2 @@
+PV = "1.0.0+git${SRCPV}"
+SRCREV = "071d2d0a2b7997d697fa1228423b329f817a237a"
diff --git a/recipes-connectivity/cannelloni/cannelloni_git.bb b/recipes-connectivity/cannelloni/cannelloni_git.bb
deleted file mode 100644 (file)
index e4a4fa7..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-SUMMARY = "A SocketCAN over Ethernet tunnel"
-HOMEPAGE = "https://github.com/mguentner/cannelloni"
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-
-SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https;branch=master \
-           file://0001-Fix-compilation-on-latest-gcc-versions.patch \
-           "
-
-PV = "1.0.0+git${SRCPV}"
-SRCREV = "aa0f0ecba2b8be0ea7ddd9952e719449a75330ec"
-
-S = "${WORKDIR}/git"
-
-inherit cmake