sllin: add patch to enable building against newer kernels 03/26103/1
authorScott Murray <scott.murray@konsulko.com>
Thu, 25 Feb 2021 21:02:40 +0000 (16:02 -0500)
committerScott Murray <scott.murray@konsulko.com>
Thu, 25 Feb 2021 21:31:14 +0000 (16:31 -0500)
Add patch to enable building the sllin driver against kernels 5.9
or newer.

Bug-AGL: SPEC-3819

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Icb99773833a79f47af3e3287e6c62d64bb344f25

recipes-kernel/sllin/files/0004-Fix-build-with-5.9-kernel.patch [new file with mode: 0644]
recipes-kernel/sllin/sllin.bb

diff --git a/recipes-kernel/sllin/files/0004-Fix-build-with-5.9-kernel.patch b/recipes-kernel/sllin/files/0004-Fix-build-with-5.9-kernel.patch
new file mode 100644 (file)
index 0000000..f3bcda9
--- /dev/null
@@ -0,0 +1,48 @@
+Use sched_set_fifo on newer kernels
+
+The 5.9 kernel removed the export of sched_setscheduler, use
+the new sched_set_fifo API if building on 5.9 or newer.  There
+is a slight difference in resulting priority level, the new
+API will yield a priority of 50 instead of the explicit value
+of 40 being used with sched_setscheduler, but this should not
+be an issue.
+
+Upstream-Status: Inappropriate [no upstream]
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+---
+diff --git a/sllin/sllin.c b/sllin/sllin.c
+index 133d6e9..92c52ad 100644
+--- a/sllin/sllin.c
++++ b/sllin/sllin.c
+@@ -1059,14 +1059,20 @@ static int sllin_kwthread(void *ptr)
+ {
+       struct sllin *sl = (struct sllin *)ptr;
+       struct tty_struct *tty = sl->tty;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,9,0)
+       struct sched_param schparam = { .sched_priority = 40 };
++#endif
+       int tx_bytes = 0; /* Used for Network statistics */
+       unsigned long flags;
+       int lin_id;
+       struct sllin_conf_entry *sce;
+       netdev_dbg(sl->dev, "sllin_kwthread started.\n");
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,9,0)
+       sched_setscheduler(current, SCHED_FIFO, &schparam);
++#else
++      sched_set_fifo(current);
++#endif
+       clear_bit(SLF_ERROR, &sl->flags);
+       sltty_change_speed(tty, sl->lin_baud);
+@@ -1274,8 +1280,8 @@ slstate_response_wait:
+                                       sl->lin_state = SLSTATE_RESPONSE_WAIT_BUS;
+                               }
+                       }
++                      fallthrough;
+-                      /* Be aware, no BREAK here */
+               case SLSTATE_RESPONSE_WAIT_BUS:
+                       if (sl->rx_cnt < sl->rx_expect)
+                               continue;
index 0478b21..f469ece 100644 (file)
@@ -17,6 +17,7 @@ SRC_URI_append = " \
        file://0002_fix_null_operation_check.patch;pnum=2 \
        file://0003-Allow-recent-kernels-newer-4.11.x-to-build.patch;pnum=2 \
        file://0001-Disable-sllin-driver-debug-log.patch;pnum=2 \
+       file://0004-Fix-build-with-5.9-kernel.patch;pnum=2 \
        file://sllin-demo.service \
        file://start_lin_demo.sh \
        file://lin_config.conf \