agl-service-radio: Rework 4A support 27/14127/2
authorScott Murray <scott.murray@konsulko.com>
Tue, 29 May 2018 01:27:33 +0000 (21:27 -0400)
committerScott Murray <scott.murray@konsulko.com>
Fri, 1 Jun 2018 01:50:17 +0000 (01:50 +0000)
Updates for changes to the binding to directly support 4A:
- the over-ride of the output sink is no longer required
- building now always requires gstreamer-1.0
- pulseaudio is now only required when building for non-4A
- set HAVE_4A_FRAMEWORK when building for 4A, as is done for
  the mediaplayer binding

Change-Id: Id0657a5a760a2dff33a84857ba206e92c640b10d
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/agl-service-radio/agl-service-radio_git.bb
recipes-demo-hmi/agl-service-radio/files/set-4a-output-sink.conf [deleted file]

index 46dc48a..34f734a 100644 (file)
@@ -2,30 +2,21 @@ SUMMARY     = "Radio Service Binding"
 DESCRIPTION = "AGL Radio Service Binding"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-radio"
 SECTION     = "apps"
-
-
 LICENSE     = "Apache-2.0 & GPLv2+"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=https;branch=${AGL_BRANCH} \
-           file://set-4a-output-sink.conf \
-"
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS = "rtl-sdr glib-2.0 pulseaudio alsa-lib"
+DEPENDS = "rtl-sdr glib-2.0 gstreamer1.0"
+DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', '' , 'pulseaudio', d)}"
 
 inherit cmake aglwgt pkgconfig
 
-do_install_append() {
-       if ${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', 'true', 'false', d)}; then
-               install -d ${D}${systemd_user_unitdir}/afm-service-agl-service-radio@1.0.service.d
-               install -m 0644 ${WORKDIR}/set-4a-output-sink.conf ${D}${systemd_user_unitdir}/afm-service-agl-service-radio@1.0.service.d/
-       fi
-}
-
-FILES_${PN} += "${systemd_user_unitdir}"
+EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', '-DHAVE_4A_FRAMEWORK=1' , '', d)}"
diff --git a/recipes-demo-hmi/agl-service-radio/files/set-4a-output-sink.conf b/recipes-demo-hmi/agl-service-radio/files/set-4a-output-sink.conf
deleted file mode 100644 (file)
index c574ca1..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-[Service]
-Environment=PULSE_SINK=alsa_output.Radio