Add html5-hvac application. 07/27107/5
authorJose Dapena Paz <jdapena@igalia.com>
Wed, 26 Jan 2022 12:00:20 +0000 (13:00 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 1 Feb 2022 21:51:08 +0000 (21:51 +0000)
Add back the html5-hvac application, adapting installation to the new
application framework:
- It provides a valid .desktop file.
- It does not use the .wgt file, and just deployes to
  /usr/lib/wam_apps/html5-hvac the application files.

Bug-AGL: SPEC-4224
Change-Id: Icee2d6bfdbd69265614581b731a76a6742036720
Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
recipes-demo/html5-hvac/files/webapps-hvac.desktop [new file with mode: 0644]
recipes-demo/html5-hvac/html5-hvac_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb

diff --git a/recipes-demo/html5-hvac/files/webapps-hvac.desktop b/recipes-demo/html5-hvac/files/webapps-hvac.desktop
new file mode 100644 (file)
index 0000000..88b1393
--- /dev/null
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 HVAC
+Comment=HVAC
+GenericName=HVAC
+Exec=env AFM_ID=webapps-hvac AFM_APP_INSTALL_DIR=/usr/lib/wam_apps/html5-hvac/ /usr/bin/WebAppMgr
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/html5-hvac/html5-hvac_git.bb b/recipes-demo/html5-hvac/html5-hvac_git.bb
new file mode 100644 (file)
index 0000000..85fed29
--- /dev/null
@@ -0,0 +1,38 @@
+SUMMARY     = "AGL HTML5 HVAC Application"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-hvac/"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git"
+B       = "${WORKDIR}/build"
+
+SRC_URI = " \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=${AGL_BRANCH} \
+  file://webapps-hvac.desktop \
+"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS = "nodejs-native"
+
+do_compile() {
+  bldcmd=${S}/autobuild/agl/autobuild
+  cd ${S}
+  $bldcmd build
+}
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
+
+do_install() {
+  install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+  cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+  install -d ${D}${APPLICATIONS_DIR}
+  install ${WORKDIR}/webapps-hvac.desktop ${D}${APPLICATIONS_DIR}
+}
+
+FILES_${PN} = " \
+  ${WAM_APPLICATIONS_DIR}/${PN} \
+  ${APPLICATIONS_DIR} \
+"
\ No newline at end of file
index adc08be..5342f07 100644 (file)
@@ -41,6 +41,7 @@ RDEPENDS:${PN}-devel = " \
 # TODO(jdapena): replace this with HTML5 apps.
 AGL_APPS = " \
     dashboard \
+    html5-hvac \
     hvac \
     ondemandnavi \
     settings \