agl-demo-platform-crosssdk: add gcc-sanitizer to TOOLCHAIN_TARGET_TASK
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
index d707874..a814b69 100755 (executable)
@@ -27,12 +27,13 @@ TOOLCHAIN_HOST_TASK += " \
     nativesdk-xz \
     nativesdk-nspr-dev \
     nativesdk-nss-dev \
+    nativesdk-lua \
     "
 
 # required dependencies for Chromium build inside SDK (SPEC-942)
 TOOLCHAIN_TARGET_TASK += " \
     pciutils-dev \
-    pulseaudio-dev \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-dev' , '', d)} \
     cairo-dev \
     nss-dev \
     cups-dev \
@@ -40,7 +41,11 @@ TOOLCHAIN_TARGET_TASK += " \
     libexif-dev \
     pango-dev \
     libdrm-dev  \
-    libssp-dev \
+    lua-dev \
+    lua-staticdev \
+    libafb-helpers-staticdev \
+    libafb-helpers-qt-staticdev \
+    libappcontroller-staticdev \
     ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'ffmpeg-dev', '', d)} \
     "
 
@@ -51,3 +56,26 @@ TOOLCHAIN_TARGET_TASK += " \
 TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
 
 TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
+
+# Add mosquitto to support building the telematics demo application.
+# This is currently required for CI, as it uses agl-demo-platform-crosssdk
+# to build everything. An agenda item has been tabled for the May 2019 F2F
+# meeting to discuss the path forward (separate versus superset SDKs), this
+# should be reviewed after that.
+TOOLCHAIN_TARGET_TASK += "mosquitto-dev"
+
+# Add nlohmann-json to support building the speech services.
+# Required until either the agl-speech-framework feature is added as a
+# dependency of agl-demo, or the speech services are migrated into the
+# core profile.
+TOOLCHAIN_TARGET_TASK += "nlohmann-json-dev"
+
+# Add libstdc++-staticdev to support building agl-service-voice-high or
+# other users of the C++17 filesystem standard library feature.
+# Can be removed upon upgrade to gcc 9.x, as it will no longer be necessary.
+TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"
+
+# Add gcc-sanitizers to support building applications using the SDK with
+# AddressSanitizer support to detect use-after-frees along with other
+# memory issue.
+TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"