Fix crosssdk image creation
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
index e6225be..9765015 100644 (file)
@@ -10,3 +10,8 @@ IMAGE_FEATURES_append = "dev-pkgs"
 IMAGE_INSTALL_append = "kernel-dev"
 
 inherit populate_sdk populate_sdk_qt5
+
+# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
+# Both exec "createrepo" on the same directory, and so one of them
+# can failed (randomly).
+addtask do_populate_sdk after do_rootfs