agl-demo-platform-crosssdk: add nlohmann-json
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
index d51ae05..7a9b728 100755 (executable)
@@ -41,10 +41,10 @@ TOOLCHAIN_TARGET_TASK += " \
     libexif-dev \
     pango-dev \
     libdrm-dev  \
-    libssp-dev \
     lua-dev \
     lua-staticdev \
     libafb-helpers-staticdev \
+    libafb-helpers-qt-staticdev \
     libappcontroller-staticdev \
     ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'ffmpeg-dev', '', d)} \
     "
@@ -57,8 +57,15 @@ TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
 
 TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
 
-# Add libvcard to the SDK to support libqtappfw
-TOOLCHAIN_TARGET_TASK += " \
-    libvcard-dev \
-    libvcard-staticdev \
-    "
+# Add mosquitto to support building the telematics demo application.
+# This is currently required for CI, as it uses agl-demo-platform-crosssdk
+# to build everything. An agenda item has been tabled for the May 2019 F2F
+# meeting to discuss the path forward (separate versus superset SDKs), this
+# should be reviewed after that.
+TOOLCHAIN_TARGET_TASK += "mosquitto-dev"
+
+# Add nlohmann-json to support building the speech services.
+# Required until either the agl-speech-framework feature is added as a
+# dependency of agl-demo, or the speech services are migrated into the
+# core profile.
+TOOLCHAIN_TARGET_TASK += "nlohmann-json-dev"