agl-demo-platform-crosssdk: add nlohmann-json
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
index a6d52e5..7a9b728 100755 (executable)
@@ -34,7 +34,6 @@ TOOLCHAIN_HOST_TASK += " \
 TOOLCHAIN_TARGET_TASK += " \
     pciutils-dev \
     ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-dev' , '', d)} \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', 'libavirt-staticdev' , '', d)} \
     cairo-dev \
     nss-dev \
     cups-dev \
@@ -58,15 +57,15 @@ TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
 
 TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
 
-# Add libvcard to the SDK to support libqtappfw
-TOOLCHAIN_TARGET_TASK += " \
-    libvcard-dev \
-    libvcard-staticdev \
-    "
-
 # Add mosquitto to support building the telematics demo application.
 # This is currently required for CI, as it uses agl-demo-platform-crosssdk
 # to build everything. An agenda item has been tabled for the May 2019 F2F
 # meeting to discuss the path forward (separate versus superset SDKs), this
 # should be reviewed after that.
 TOOLCHAIN_TARGET_TASK += "mosquitto-dev"
+
+# Add nlohmann-json to support building the speech services.
+# Required until either the agl-speech-framework feature is added as a
+# dependency of agl-demo, or the speech services are migrated into the
+# core profile.
+TOOLCHAIN_TARGET_TASK += "nlohmann-json-dev"