agl-demo-platform-crosssdk: add nlohmann-json
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
old mode 100644 (file)
new mode 100755 (executable)
index 6df9521..7a9b728
@@ -27,12 +27,13 @@ TOOLCHAIN_HOST_TASK += " \
     nativesdk-xz \
     nativesdk-nspr-dev \
     nativesdk-nss-dev \
+    nativesdk-lua \
     "
 
 # required dependencies for Chromium build inside SDK (SPEC-942)
 TOOLCHAIN_TARGET_TASK += " \
     pciutils-dev \
-    pulseaudio-dev \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-dev' , '', d)} \
     cairo-dev \
     nss-dev \
     cups-dev \
@@ -40,7 +41,31 @@ TOOLCHAIN_TARGET_TASK += " \
     libexif-dev \
     pango-dev \
     libdrm-dev  \
-    libssp-dev \
-    ffmpeg-dev \
+    lua-dev \
+    lua-staticdev \
+    libafb-helpers-staticdev \
+    libafb-helpers-qt-staticdev \
+    libappcontroller-staticdev \
+    ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'ffmpeg-dev', '', d)} \
     "
 
+# Add wayland-scanner to SDK (SPEC-945)
+# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
+# wayland-scanner is in nativesdk-wayland-dev !
+# option: add also nativesdk-qtwayland-tools
+TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
+
+TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
+
+# Add mosquitto to support building the telematics demo application.
+# This is currently required for CI, as it uses agl-demo-platform-crosssdk
+# to build everything. An agenda item has been tabled for the May 2019 F2F
+# meeting to discuss the path forward (separate versus superset SDKs), this
+# should be reviewed after that.
+TOOLCHAIN_TARGET_TASK += "mosquitto-dev"
+
+# Add nlohmann-json to support building the speech services.
+# Required until either the agl-speech-framework feature is added as a
+# dependency of agl-demo, or the speech services are migrated into the
+# core profile.
+TOOLCHAIN_TARGET_TASK += "nlohmann-json-dev"