fix MOST driver dependency issues
[AGL/meta-agl-demo.git] / recipes-kernel / aim-cdev / aim-cdev.bb
diff --git a/recipes-kernel/aim-cdev/aim-cdev.bb b/recipes-kernel/aim-cdev/aim-cdev.bb
deleted file mode 100644 (file)
index e8c101e..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Build character device driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
-    # modprobe automatically at boot
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -d ${D}${sysconfdir}/modules-load.d
-        echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
-    fi
-}