wayland: add .desktop file for weston-terminal
[AGL/meta-agl-demo.git] / recipes-graphics / wayland / weston-terminal-conf.bb
diff --git a/recipes-graphics/wayland/weston-terminal-conf.bb b/recipes-graphics/wayland/weston-terminal-conf.bb
new file mode 100644 (file)
index 0000000..4bf864f
--- /dev/null
@@ -0,0 +1,20 @@
+SUMMARY = "AGL user session"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = " \
+    file://weston-terminal.desktop \
+"
+
+inherit allarch
+
+do_install() {
+    install -d ${D}${datadir}/applications
+    install -m 0644 ${WORKDIR}/weston-terminal.desktop ${D}${datadir}/applications
+}
+
+FILES:${PN} = "${datadir}/applications"
+
+RDEPENDS:${PN} = " \
+    weston \
+"