python3-pyqt5: enable SVG support
[AGL/meta-agl-demo.git] / recipes-devtools / python / python3-pyqt5_5.15.1.bbappend
diff --git a/recipes-devtools/python/python3-pyqt5_5.15.1.bbappend b/recipes-devtools/python/python3-pyqt5_5.15.1.bbappend
new file mode 100644 (file)
index 0000000..408c48b
--- /dev/null
@@ -0,0 +1,9 @@
+# Enable SVG support
+DEPENDS:append = " qtsvg"
+PYQT_MODULES:append = " QtSvg"
+
+# Fix python interpreter paths in pyrcc5, etc., adapted from newer upstream
+# recipe
+do_install:append() {
+    sed -i "s,^exec .*python${PYTHON_BASEVERSION},exec ${bindir}/python3," ${D}/${bindir}/*
+}