Migrate poiapp and libnaviapi-agl to AGL Gerrit
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / poiapp_git.bb
old mode 100755 (executable)
new mode 100644 (file)
index 94753fe..87263e1
@@ -6,19 +6,15 @@ SECTION     = "apps"
 LICENSE          = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
 
-inherit cmake_qt5 pkgconfig
-inherit aglwgt
-
-DEPENDS += " qtbase json-c libnaviapi-agl \
-             af-binder qlibwindowmanager virtual/libhomescreen \
+DEPENDS += "qtbase json-c libnaviapi-agl \
+            qlibwindowmanager libhomescreen \
            "
 
-RDEPENDS_${PN} =  " qtbase \
-                  "
-
-SRCREV = "21b67b326181cd4280d1482e028126ae7ba4b680"
-SRC_URI = "git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=agl \
-          "
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
+inherit cmake_qt5 pkgconfig aglwgt
+
+RDEPENDS_${PN} =  "qtbase"