Migrate poiapp and libnaviapi-agl to AGL Gerrit
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / poiapp_git.bb
old mode 100755 (executable)
new mode 100644 (file)
index 3bdac9e..87263e1
@@ -6,25 +6,15 @@ SECTION     = "apps"
 LICENSE          = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
 
-inherit cmake_qt5 pkgconfig
-inherit aglwgt
-
-DEPENDS += " qtbase libdbus-c++ json-c zip-native \
+DEPENDS += "qtbase json-c libnaviapi-agl \
+            qlibwindowmanager libhomescreen \
            "
 
-SRCREV="3e162a60c76dee1b4dede81db55e0fa6bae05433"
-SRC_URI="git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=agl \
-         file://config.xml \
-"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
-do_install_append() {
-   mkdir -p ${WORKDIR}/widget
-   install -m 0644 ${WORKDIR}/config.xml ${WORKDIR}/widget
-   install -m 0755 ${D}/usr/bin/yelp-client ${WORKDIR}/widget/poi
-
-   mkdir -p ${B}/package
-   zip -ju ${B}/package/poi.wgt ${WORKDIR}/widget/poi ${WORKDIR}/widget/config.xml
+inherit cmake_qt5 pkgconfig aglwgt
 
-}
+RDEPENDS_${PN} =  "qtbase"