Migrate poiapp and libnaviapi-agl to AGL Gerrit
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / poiapp_git.bb
index 02a0fa0..87263e1 100644 (file)
@@ -1,28 +1,20 @@
-LICENSE="GPLv2"
-LIC_FILES_CHKSUM="file://LICENSE;md5=53633740548e7211116fc17bbe20aaf8"
+SUMMARY     = "AGL Reference POI application."
+DESCRIPTION = "This application provides the function of destination search to AGL.  It uses the API provided by AGL Reference Navigation.  This application uses yelp WebAPI."
+HOMEPAGE    = "https://github.com/AGLExport/genivi-navi-yelp-client"
+SECTION     = "apps"
 
-inherit cmake_qt5 pkgconfig
+LICENSE          = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
 
-DEPENDS += " qtbase libdbus-c++ json-c \
+DEPENDS += "qtbase json-c libnaviapi-agl \
+            qlibwindowmanager libhomescreen \
            "
 
-SRCREV="4e09ab88d0d97c59896ba66bf08a8e006e2af81a"
-SRC_URI="git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=new-layout \
-         file://config.xml \
-"
-
-RDEPENDS_${PN} = " navigation "
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
-do_install_append() {
-   mkdir -p ${WORKDIR}/widget
-   install -m 0644 ${WORKDIR}/config.xml ${WORKDIR}/widget
-   install -m 0755 ${D}/usr/bin/yelp-client ${WORKDIR}/widget/poi
-   zip -ju ${WORKDIR}/widget/poi.wgt ${WORKDIR}/widget/poi ${WORKDIR}/widget/config.xml
-
-   install -d ${D}/usr/AGL/apps
-   install -m 0644 ${WORKDIR}/widget/poi.wgt ${D}/usr/AGL/apps/
-}
+inherit cmake_qt5 pkgconfig aglwgt
 
-FILES_${PN} += " /usr/AGL/apps/poi.wgt "
+RDEPENDS_${PN} =  "qtbase"