navigation: Switch to pipewire output
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / navigation_git.bb
index bc62ef4..fefc058 100644 (file)
@@ -9,21 +9,26 @@ LIC_FILES_CHKSUM="file://LICENSE;md5=3595e9c703a847d990664d2b396a9df0 \
 
 DEPENDS = " \
           glib-2.0 freetype sqlite3 wayland zlib expat openssl virtual/libgles2 virtual/libgl virtual/egl \
-          wayland libdbus-c++ af-main \
+          wayland libdbus-c++ af-main af-binder libwindowmanager libhomescreen gstreamer1.0 \
           "
 
 RDEPENDS_${PN} = " flite openjtalk glib-2.0 freetype sqlite3 wayland zlib expat openssl \
-                   wayland libdbus-c++ af-main "
+                   wayland libdbus-c++ af-main gstreamer1.0"
 
-SRCREV="c6403c1147fa53cd6a638f738d270c5d3bb214cf"
+RDEPENDS_${PN} += " agl-service-navigation "
+
+SRCREV="89dc0052aced411ef09f8e0034fb5cf2c96ee637"
 SRC_URI="git://github.com/AGLExport/gpsnavi.git;branch=agl \
-         file://flite.in \
-         file://jtalk.in \
+         file://0001-switch-to-pipewire-output.patch \
+         file://0002-openssl-1.1-fixes.patch \
+         file://0003-update-permissions.patch \
          file://download_mapdata_jp.sh \
          file://download_mapdata_uk.sh \
-         file://0001-Makefile-compatible-aglwgt.patch \
+         file://org.agl.naviapi.conf \
 "
 
+RPROVIDES_${PN} = "virtual/navigation"
+
 # To avoid C++ library link failure
 SECURITY_CFLAGS = ""
 
@@ -32,32 +37,16 @@ inherit aglwgt
 
 S = "${WORKDIR}/git"
 
-do_compile_prepend() {
-   cp ${WORKDIR}/flite.in ${S}/
-   cp ${WORKDIR}/jtalk.in ${S}/
-}
-
 do_install_append() {
-   # Attention: BUG: app ships native lib as part of platform
-   # see SPEC-785 and SPEC-384
-   # /start FIXME __________________
-     cd ${B}
-     oe_runmake 'DESTDIR=${D}' install
-     rm ${D}/usr/bin/navi
-   # /end   FIXME ^^^^^^^^^^^^^^^^^^^
-
+# mapdata install scripts
    install -d ${D}/usr/AGL/apps
-   mkdir -p ${B}/package/
-   mv ${B}/navigation.wgt ${B}/package/
    install -m 0755 ${WORKDIR}/download_mapdata_jp.sh ${D}/usr/AGL/apps/
    install -m 0755 ${WORKDIR}/download_mapdata_uk.sh ${D}/usr/AGL/apps/
 
+   install -d ${D}/etc/dbus-1/session.d/
+   install -m 0644 ${WORKDIR}/org.agl.naviapi.conf ${D}/etc/dbus-1/session.d/
+
    install -d ${D}/var/mapdata
 }
-#it's Workaround
-EXTRA_WGT_POSTINSTALL = "\
-        cyad -s -k MANIFESTS -t allow -c User::App::navigation -u '*' -p 'http://tizen.org/privilege/internal/dbus';\
-        cyad -s -k MANIFESTS -t allow -c User::App::poi -u '*' -p 'http://tizen.org/privilege/internal/dbus';\
-"
 
 FILES_${PN} += " /usr/AGL/apps/*.sh /var/mapdata "