mixer: update to build the pipewire mixer from master
[AGL/meta-agl-demo.git] / recipes-demo-hmi / mixer / mixer_git.bb
index c7f30a1..9524bed 100644 (file)
@@ -1,34 +1,29 @@
 SUMMARY     = "Mixer for CES2017 AGL Demonstration"
-DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
+DESCRIPTION = "AGL HMI application for control of PipeWire mixer elements"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
-LICENSE     = "Apache-2.0"
 SECTION     = "apps"
 
-PV = "1.0+git${SRCPV}"
-S  = "${WORKDIR}/git"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-inherit qmake5
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
-DEPENDS += "qtquickcontrols2"
-# 'wgtpkg-pack' in af-main-native is required.
-DEPENDS += "af-main-native"
-DEPENDS += "pulseaudio"
+PV = "1.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
 
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 \
+            qtwebsockets \
+            qtaglextras \
+            libafb-helpers-qt \
+"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=http"
-SRCREV  = "${AUTOREV}"
+RDEPENDS_${PN} += "agl-service-audiomixer"
 
-RDEPENDS_${PN} += " \
-    qtmultimedia-qmlplugins \
-    qtquickcontrols2-qmlplugins \
-    "
+PROVIDES += "virtual/mixer"
+RPROVIDES_${PN} += "virtual/mixer"
 
-do_install() {
-    install -d ${D}/usr/AGL/apps
-    install -m 0644 ${B}/package/${PN}.wgt ${D}/usr/AGL/apps/
-}
+inherit cmake_qt5 aglwgt
 
-FILES_${PN} += "/usr/AGL/apps/ \
-    /usr/AGL/apps/${PN} \
-    "
+OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"