Update app DEPENDS for new HMI framework
[AGL/meta-agl-demo.git] / recipes-demo-hmi / mediaplayer / mediaplayer_git.bb
index 8a7fd62..e99eb5b 100644 (file)
@@ -12,10 +12,15 @@ SRCREV  = "${AGL_APP_REVISION}"
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-inherit qmake5 aglwgt
-
 # build-time dependencies
-DEPENDS += "sqlite3 qtquickcontrols2 qtmultimedia"
+DEPENDS += "sqlite3 \
+            qtquickcontrols2 \
+            qtmultimedia \
+            virtual/libhomescreen \
+            qlibwindowmanager \
+"
+
+inherit qmake5 aglwgt
 
 RDEPENDS_${PN} += "qtmultimedia \
                    qtmultimedia-qmlplugins \