html5-dashboard: create recipe and add to html5 demo
[AGL/meta-agl-demo.git] / recipes-demo-hmi / html5-dashboard / html5-dashboard_git.bb
diff --git a/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb b/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb
new file mode 100644 (file)
index 0000000..534bd2d
--- /dev/null
@@ -0,0 +1,25 @@
+SUMMARY     = "AGL HTML5 dashboard Application"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-dashboard/"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+  cd ${B}
+  npm install
+}
+
+do_aglwgt_package()  {
+  cd ${B}
+  npm run build
+}