homescreen-demo-ci: Recipe for homescreen-demo-ci
[AGL/meta-agl-demo.git] / recipes-demo-hmi / homescreen-demo-ci / homescreen-demo-ci_git.bb
diff --git a/recipes-demo-hmi/homescreen-demo-ci/homescreen-demo-ci_git.bb b/recipes-demo-hmi/homescreen-demo-ci/homescreen-demo-ci_git.bb
new file mode 100644 (file)
index 0000000..c3814f1
--- /dev/null
@@ -0,0 +1,37 @@
+SUMMARY     = "homescreen-demo-ci AGL client shell for testing in CI"
+DESCRIPTION = "homescreen-demo-ci AGL client shell for testing in CI"
+HOMEPAGE    = "http://docs.automotivelinux.org"
+LICENSE     = "MIT"
+SECTION     = "apps"
+LIC_FILES_CHKSUM = "file://COPYING;md5=374fee6a7817f1e1a5a7bfb7b7989553"
+
+DEPENDS = "\
+        qtbase \
+        qtdeclarative \
+        qtquickcontrols2 \
+        agl-service-homescreen \
+        agl-service-weather \
+        libqtappfw \
+        libhomescreen \
+        libafb-helpers-qt \
+        wayland-native \
+        wayland \
+        qtwayland \
+        qtwayland-native \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen-demo-ci;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+
+OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+
+RDEPENDS_${PN} += " \
+        libqtappfw \
+"