mediaplayer: remove qtmultimedia dependencies from recipe
[AGL/meta-agl-demo.git] / recipes-webruntime / webkitforwayland / webkitforwayland_git.bb
1 SUMMARY = "WebKit for Wayland port pairs the WebKit engine with the Wayland display protocol, \
2            allowing embedders to create simple and performant systems based on Web platform technologies. \
3            It is designed with hardware acceleration in mind, relying on EGL, the Wayland EGL platform, and OpenGL ES."
4 HOMEPAGE = "http://www.webkitforwayland.org/"
5 LICENSE = "BSD & LGPLv2+"
6 LIC_FILES_CHKSUM = "file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 "
7
8 # you need harfbuzz with icu enabled, you can add this to your config:
9 # PACKAGECONFIG_append_pn-harfbuzz = " icu" if you are having problems
10 # with the do_configure step and harfbuzz.
11 DEPENDS = "zlib enchant libsoup-2.4 curl libxml2 cairo libxslt libidn gnutls \
12            gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native icu \
13            gperf-native perl-native ruby-native sqlite3 \
14            libwebp harfbuzz virtual/libgles2 wayland weston mesa"
15
16
17 REQUIRED_DISTRO_FEATURES = "wayland"
18
19 inherit cmake pkgconfig perlnative pythonnative
20
21 #
22 # We download a tarball from github instead of cloning the git repository because
23 # requires less resources (network bandwidth and disk space) on the build machine.
24 #
25 # PV is the release or tag version (from https://github.com/WebKitForWayland/webkit/releases)
26 PV = "wpe-20160519"
27 S = "${WORKDIR}/webkit-${PV}/"
28
29 SRC_URI = "\
30    https://github.com/WebKitForWayland/webkit/archive/${PV}.tar.gz \
31 "
32
33 SRC_URI[md5sum] = "2b5f254c426ec74d62a72e136cf5e274"
34 SRC_URI[sha256sum] = "f4f5076b2f7e17e86976bb14dffc750b446392b1e68946eea9dd0d733ec5f5f2"
35
36 EXTRA_OECMAKE = " \
37                  -DPORT=WPE \
38                  -DCMAKE_BUILD_TYPE=Release \
39                 "
40
41 # Javascript JIT is not supported on powerpc
42 EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
43 EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
44
45 # ARM JIT code does not build on ARMv5/6 anymore, apparently they test only on v7 onwards
46 EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
47 EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
48
49 # binutils 2.25.1 has a bug on aarch64:
50 # https://sourceware.org/bugzilla/show_bug.cgi?id=18430
51 EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF "
52
53 # JIT not supported on MIPS either
54 EXTRA_OECMAKE_append_mips = " -DENABLE_JIT=OFF "
55 EXTRA_OECMAKE_append_mips64 = " -DENABLE_JIT=OFF "
56
57 # We manually set the includes files for the binary and dev package here,
58 # (overriding the default settings) because some libraries (libWPE and
59 # libWPEWebInspectorResources) are not versioned, so we must include
60 # the .so file in the binary package instead of the dev one.
61 FILES_${PN}-dev = " \
62 ${includedir} \
63 ${libdir}/libWPE.so \
64 ${libdir}/libWPEWebKit.so \
65 ${libdir}/pkgconfig \
66 "
67 FILES_${PN} = " \
68 ${bindir} \
69 ${libdir}/libWPE.so.* \
70 ${libdir}/libWPEWebInspectorResources.so \
71 ${libdir}/libWPEWebKit.so.* \
72 "
73
74 RRECOMMENDS_${PN} += "ca-certificates"