wam: use gRPC for internal IPC.
[AGL/meta-agl-demo.git] / recipes-wam / wam / wam_git.bb
1 SUMMARY = "WAM"
2 AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6 inherit cmake pkgconfig
7
8 DEPENDS = "glib-2.0 jsoncpp boost chromium protobuf protobuf-native grpc grpc-native"
9
10 EXTRA_OECMAKE = "\
11     -DCMAKE_BUILD_TYPE=Release \
12     -DCMAKE_INSTALL_PREFIX=${prefix} \
13     -DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
14     -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium"
15
16 PR="r0"
17
18 PROVIDES += "virtual/webruntime"
19 RPROVIDES:${PN} += "virtual/webruntime"
20
21 # Disable some of securit_flags
22 # Disable D_FORTIFY_SOURCE=2 and -fstack-protector-strong
23 # Refer conf/distro/include/security_flags.inc in meta-webos/conf/distro/include/webos.inc
24 lcl_maybe_fortify = ""
25 SECURITY_STACK_PROTECTOR = ""
26
27 SRC_URI = "\
28     git://github.com/igalia/${BPN}.git;branch=@58.agl;protocol=https \
29     file://WebAppMgr.service \
30     file://WebAppMgr.env \
31 "
32 S = "${WORKDIR}/git"
33 SRCREV = "8ea41f7b59b52ef005f6f932e3335bfd137aa5fa"
34
35 PV = "ose58.agl"
36
37 do_install:append() {
38     install -v -d ${D}${sysconfdir}/wam
39     install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
40     install -v -d ${D}${systemd_user_unitdir}
41     install -v -m 644 ${WORKDIR}/WebAppMgr.service ${D}${systemd_user_unitdir}/WebAppMgr.service
42     install -v -d ${D}${sysconfdir}/default/
43     install -v -m 644 ${WORKDIR}/WebAppMgr.env ${D}${sysconfdir}/default/WebAppMgr.env
44     ln -snf WebAppMgr ${D}${bindir}/web-runtime
45     install -v -d ${D}${systemd_user_unitdir}/agl-session.target.wants
46     ln -sf ../WebAppMgr.service ${D}${systemd_user_unitdir}/agl-session.target.wants/
47 }
48
49 FILES:${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_user_unitdir}"
50
51 CXXFLAGS:append:agl-devel = " -DAGL_DEVEL"
52
53 do_install:append:agl-devel() {
54     # Enable remote inspector and dev mode
55     install -d ${D}${localstatedir}/agl-devel/preferences
56     touch ${D}${localstatedir}/agl-devel/preferences/debug_system_apps
57     touch ${D}${localstatedir}/agl-devel/preferences/devmode_enabled
58 }