Prepare master for new framework integration
[AGL/meta-agl-demo.git] / recipes-wam / chromium / chromium84_git.bb
1 require chromium.inc
2
3 SRC_URI = "\
4     git://github.com/igalia/${PN};branch=koi;protocol=https;rev=${SRCREV_chromium84};name=chromium84 \
5     git://github.com/webosose/chromium-v8;branch=@chromium84;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8;protocol=https \
6     file://add-a-delay-to-agl-ready-event.patch \
7     file://chromium-quiche-invalid-offsetof.patch \
8     file://chromium-skia-no_sanitize.patch \
9 "
10
11 # Needed by catapult
12 DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
13
14 SRCREV_chromium84 = "17ab9d58b9d5da9102b119d39cf49a002e61ea1b"
15 SRCREV_v8 = "5c1d89dd2945a10cf7a6a3458050b3177a870b09"
16
17 BROWSER_APPLICATION = "chromium84-browser"
18 BROWSER_APPLICATION_DIR = "/opt/chromium84"
19 MKSNAPSHOT_PATH = "v8_snapshot/"
20
21 PACKAGECONFIG:remove="jumbo"
22
23 GN_ARGS += "use_gtk=false"
24
25 # Disable closure_compile
26 # Else we need HOSTTOOLS += "java"
27 GN_ARGS += "closure_compile=false"
28
29 # When using meta-clang, one can switch to using the lld linker
30 # by using the ld-is-lld distro feature otherwise use gold linker
31 GN_ARGS += "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', 'use_lld=true use_gold=false', bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'use_lld=false use_gold=true', 'use_lld=false use_gold=false', d), d)}"
32
33 # Toolchains we will use for the build. We need to point to the toolchain file
34 # we've created, set the right target architecture and make sure we are not
35 # using Chromium's toolchain (bundled clang, bundled binutils etc).
36 GN_ARGS += "\
37     host_toolchain=\"//build/toolchain/cros:host\" \
38     cros_host_is_clang=false \
39     use_custom_libcxx_for_host=false \
40     cros_host_ar=\"${BUILD_AR}\" \
41     cros_host_cc=\"${BUILD_CC} ${BUILD_CFLAGS}\" \
42     cros_host_cxx=\"${BUILD_CXX} ${BUILD_CXXFLAGS}\" \
43     cros_host_extra_ldflags=\"${BUILD_LDFLAGS}\" \
44     custom_toolchain=\"//build/toolchain/cros:target\" \
45     is_clang=false \
46     use_custom_libcxx=false \
47     target_cpu=\"${@gn_arch_name('${TUNE_ARCH}')}\" \
48     cros_target_ar=\"${AR}\" \
49     cros_target_cc=\"${CC}\" \
50     cros_target_cxx=\"${CXX}\" \
51     cros_target_extra_ldflags=\"${LDFLAGS}\" \
52     v8_snapshot_toolchain=\"//build/toolchain/cros:v8_snapshot\" \
53     cros_v8_snapshot_is_clang=false \
54     cros_v8_snapshot_ar=\"${BUILD_AR}\" \
55     cros_v8_snapshot_cc=\"${BUILD_CC}\" \
56     cros_v8_snapshot_cxx=\"${BUILD_CXX}\" \
57     linux_use_bundled_binutils=false \
58     gold_path=\"\" \
59     v8_enable_embedded_builtins=false \
60     use_v8_context_snapshot=false \
61 "
62
63 GN_ARGS:append = " \
64   use_system_minigbm=false \
65   use_wayland_gbm=false \
66 "
67
68 GN_ARGS:append = " \
69   is_webos=false \
70   is_agl=true \
71 "
72
73 # TODO: drop this after we migrate to ubuntu 16.04 or above
74 GN_ARGS += "\
75     fatal_linker_warnings=false\
76 "
77
78 # TODO(rzanoni) copied from original recipe to fix qemux86 build.
79 # check if it can be removed in the future.
80 PACKAGECONFIG:remove:qemux86 = "gstreamer umediaserver neva-media gav neva-webrtc"
81 #END TODO