Update pyagl SRCREV to add audiomixer update
[AGL/meta-agl-demo.git] / recipes-test / pyagl / pyagl_git.bb
1 SUMMARY = "Python bindings and tests for Automotive Grade Linux services"
2 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/pyagl"
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
5
6 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/pyagl;protocol=https;branch=${AGL_BRANCH}"
7 SRCREV = "137a32d3b0068e2141ed9aab23d8a8956c0cb094"
8 PV = "${AGL_BRANCH}+git${SRCPV}"
9
10 S = "${WORKDIR}/git"
11
12 inherit setuptools3
13
14 do_install_append() {
15     install -D -m 0755 ${S}/pyagl/scripts/pyagl ${D}${bindir}/pyagl
16 }
17
18 RDEPENDS_${PN} += " \
19     python3-asyncio \
20     python3-asyncssh \
21     python3-core \
22     python3-json \
23     python3-logging \
24     python3-math \
25     python3-parse \
26     python3-pprint \
27     python3-pytest \
28     python3-pytest-asyncio \
29     python3-pytest-dependency \
30     python3-pytest-reverse \
31     python3-typing \
32     python3-websockets \
33 "