422f514e8e6e900823c3a9c38557426599c33678
[AGL/meta-agl-demo.git] / recipes-test / gcovr / gcovr_git.bb
1 SUMMARY = "Generate GCC code coverage reports"
2 DESCRIPTION = "Gcovr provides a utility for managing the use of the GNU gcov \
3 utility and generating summarized code coverage results."
4 HOMEPAGE = "https://gcovr.com"
5 LICENSE = "BSD-3-Clause"
6 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=221e634a1ceafe02ef74462cbff2fb16"
7
8 PV = "4.2+git${SRCPV}"
9 SRC_URI = "git://github.com/gcovr/gcovr.git;protocol=https;branch=master"
10 SRCREV = "1bc72e3bb59b9296e962b350691732ddafbd3195"
11
12 S = "${WORKDIR}/git"
13
14 inherit setuptools3
15
16 RDEPENDS:${PN} += " \
17     python3-compression \
18     python3-core \
19     python3-crypt \
20     python3-datetime \
21     python3-difflib \
22     python3-io \
23     python3-jinja2 \
24     python3-json \
25     python3-lxml \
26     python3-multiprocessing \
27     python3-pygments \
28     python3-pytest \
29     python3-shell \
30     python3-threading \
31     python3-typing \
32 "