SPEC-3723: restructure meta-agl-demo
[AGL/meta-agl-demo.git] / recipes-test / afb-test / afb-test_git.bb
1 SUMMARY = "Binding embedding test framework to test others binding"
2 DESCRIPTION = "This make testing binding running with Application Framework binder \
3 easier by simply test verb return as well as event reception."
4 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/app-afb-test"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7 SECTION = "apps"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/app-afb-test;protocol=https;branch=${AGL_BRANCH}"
10 SRCREV = "${AGL_APP_REVISION}"
11
12 DEPENDS += "lua libafb-helpers libappcontroller"
13 RDEPENDS_${PN} += "lua bash jq"
14 RDEPENDS_${PN}-ptest += "af-binder"
15
16 PV = "${AGLVERSION}"
17 S  = "${WORKDIR}/git"
18
19 inherit cmake aglwgt pkgconfig ptest
20
21 do_install_append() {
22        install -d ${D}${bindir}
23        install -m 775 ${S}/afm-test.target.sh ${D}${bindir}/afm-test
24 }
25