Update LIN demo to use lin-config
[AGL/meta-agl-demo.git] / recipes-support / lin-config / lin-config_git.bb
1 DESCRIPTION = "lin-config tool for the sllin driver module"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5 DEPENDS += "libnl libxml2"
6
7 SRC_URI = "git://github.com/trainman419/linux-lin.git;protocol=https"
8 SRCREV = "155d885e8ccc907a56f6c86c4b159fac27ef6fec"
9 S = "${WORKDIR}/git/lin_config/src"
10
11 SRC_URI_append = " \
12         file://0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch \
13         file://0002-Change-Makefile-to-use-LDFLAGS.patch \
14         "
15
16 inherit pkgconfig
17
18 PV = "0.1+git${SRCPV}"
19
20 do_configure[noexec] = "1"
21
22 do_install_append() {
23     install -d ${D}/${bindir}
24     install -m 755 ${S}/lin_config ${D}/${bindir}
25 }