fix qt-qrcode memory corruption
[AGL/meta-agl-demo.git] / recipes-qt / qt-qrcode / qt-qrcode_git.bb
1 SUMMARY = "Qt QR code library"
2 DESCRIPTION = "Qt/C++ library for encoding and visualization of data in a \
3 QR Code symbol. This library consists of a Qt wrapper for libqrencode, and \
4 Qt components that are able to visualize the result."
5 LICENSE = "LGPLv3+"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=94a3f3bdf61243b5e5cf569fbfbbea52"
7
8 DEPENDS = "qtbase qtdeclarative qtquickcontrols2 qtsvg qrencode"
9
10 SRC_URI = "git://github.com/danielsanfr/qt-qrcode.git;protocol=https \
11            file://0001-rework-library-build.patch \
12            file://0002-fix-dangling-pointer.patch \
13            "
14 SRCREV = "2d57d9c6e2341689d10f9360a16a08831a4a820b"
15
16 PV = "git${SRCPV}"
17 S = "${WORKDIR}/git/"
18
19 inherit qmake5